Skip to Content

issue with the GR output using smartform

Hi ,

I am doing output for a GR and the smartform name is determined dynamically in the driver prog based on TNAPR table, Now I printing it for a custom output type so my requirement is it should not be printing for movement types other than 101, please suggest how to do that .

That means it should kick off the form and place an prior condition on the form for checking movement type and if the movement type is not satisfied, exit from the form without printing .



Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Nov 03, 2016 at 05:25 AM

    I hope in driver program you definately capture the Gr number. Check the movement type in GR number If any 101 movement type
    write If Condition like

    If No

    lv_name = 'Smartform1'

    else if lv_name = 'Smartform2'.

    else if lv_name = 'Smartform3'.

    elseif lv_name = 'Smartform4'.


    Any problem.

    Add comment
    10|10000 characters needed characters exceeded

    • The condition is If condition only.What i said in previous.

      Data:V(10) type c,

      check in grn if any 101 movement is there , then make it false else True.

      if v eq 'true'.

      open the smart form.


  • avatar image
    Former Member
    Nov 03, 2016 at 11:58 AM

    Hi Ramya,

    You can use exception options in smartfroms.

    you can find it in Form interface --> Exception tabs.

    Declare one exception in this tab. Then Goto Global Definitions --> Initialization tab. Write a small piece of code that,

    if (movement type) ne '101'.

    (Raise your custom exception ).



    Sivaraj Sadasivam.

    Add comment
    10|10000 characters needed characters exceeded