Skip to Content

Disable 'Select Transaction Type' popup

Hi Everyone,

For 'IN' business role, when clicking 'Case Creation' from work center panel, then 'Select Transaction type' pop-up is appearing with list of transaction types. Need to avoid pop-up and directly get the 'IN' Case Creation Screen. Please advice.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • May 01 at 05:24 AM

    Hi Raza,

    Do you need the other transaction types that are appearing on the list? If not, in the transaction customization you might use this two simple options:

    - Just fill the channel attribute which desired scenario for desired transactions that are in use. Example: The transaction that you use in your IC add in channel list 'ICW Interaction Center Webclient'

    - Fill the 'inactive' attribute with inactive or blocked for online maintenance;

    If there's only one transaction type to be displayed on the list, the popup will not appear.

    See if this helps you a little more.

    Kind regards,
    Garcia

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Bruno,

      Thanks for the reply. Now its working. I debugged with reference to another role which was working and found solution.

      Need to set Business Role Type as 'IC WebClient Business Role'.

      Thanks Anyways. Regards Raza.

  • May 02 at 12:51 PM

    Hi,

    Which transaction types show up in the popup is specified in the business transaction profile assigned to your IC WebClient business role.

    If you want to create a work center dedicated for one specific transaction type you can achieve it by help of logical link customizing.

    Check work center IC_UIU_SRQ used in navigation bar profile IC_AGENT as an example. It points to logical IC_UIU_SRQ. Here the UI object type and the transaction type (CRM_SRQM_INCIDENT:SRVR) is specified directly in the logical link parameter which prevents the popup and automatically creates a new transaction with type SRVR.

    Best Regards,
    Sigrid

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Sigrid,

      Thanks for the reply. Now its working. I debugged with reference to another role which was working and found solution.

      Need to set Business Role Type as 'IC WebClient Business Role'.

      Thanks Anyways. Regards Raza.