Skip to Content
avatar image
Former Member

SAP PI passing data to PSA table of BI syatem

Dear Experts,

Scenario:

MDM---- >PI ---->BI

Eventhough when i see the success flag in the reciving side BI in SXMB_MONI. In BI not able to see any values in PSA table.There are no values in the table.

I am using server Proxy to puh the data into PSA table.

Server proxy code as follows:

method ZII_DATA_TO_BW~EXECUTE_ASYNCHRONOUS.

DATA: l_text TYPE string,

l_s_data TYPE line of /BIC/WCQSENDXML00001000,

l_t_data TYPE /BIC/WCQSENDXML00001000.

FIELD-SYMBOLS <l_line> LIKE LINE OF input-data-item.

LOOP AT input-data-item ASSIGNING <l_line>.

MOVE-CORRESPONDING <l_line> TO l_s_data.

APPEND l_s_data TO l_t_data.

ENDLOOP.

CALL FUNCTION '/BIC/CQSENDXML00001000'

EXPORTING

data = l_t_data

EXCEPTIONS

OTHERS = 1.

IF sy-subrc NE 0.

MESSAGE ID sy-msgid TYPE sy-msgty NUMBER sy-msgno

WITH sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4 INTO l_text.

RAISE EXCEPTION TYPE ZCX___BIC__CQSENDXML00001000_E

EXPORTING text = l_text.

ENDIF.

endmethod.

Kindly tell me what i need to do...

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 21, 2008 at 05:28 AM

    Hi,

    Have u tested u r server proxy interface in the BI system Itself? Select u r Inbound Proxy interface in SPROXY tcode and test it using Proxy---->Test Interface.

    Regards,

    Ganesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 21, 2008 at 05:39 AM
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I have tested my server proxy code.

      it is passing only empty values.

      when i place debugging point in function module and execute it.

      In PSA table I am seeing only null values.

      Kindly guide what i need to do..

      Take care,

      Kartthik