Skip to Content
avatar image
Former Member

DMEE File Data->Character Definition->Charact.:Not saving to DMEE_TREE_HEAD

I'm trying to save characters not to be used in my layout. Every time I save, the field clears and nothing new gets saved to the underlying table. Has anyone else encountered this issue? Is there a resolution? Please let me know thanks.

My Info:

SAP_BASIS 620 0058 SAPKB62058 SAP Basis Component

SAP_ABA 620 0058 SAPKA62058 Cross-Application Component

SAP_APPL 470 0025 SAPKH47025 Logistics and Accounting

SAP_HR 470 0010 SAPKE47010 Human Resources

EA-IPPE 200 0020 SAPKGPIB20 SAP_iPPE

PI 2004_1_470 0015 SAPKIPZI5F PI_2004_1_for_R3_Release_470

PI_BASIS 2005_1_620 0000 - PI_BASIS 2005_1_620

ST-PI 2005_1_620 0008 SAPKITLQG8 SAP Solution Tools Plug-In

EA-APPL 110 0021 SAPKGPAA21 SAP R/3 Enterprise PLM, SCM, Financials

EA-FINSERV 110 0006 SAPKGPFA06 SAP R/3 Enterprise Financial Services

EA-GLTRADE 110 0006 SAPKGPGA06 SAP R/3 Enterprise Global Trade

EA-HR 110 0010 SAPKGPHA10 SAP R/3 Enterprise HR Extension

EA-PS 110 0006 SAPKGPPA06 SAP R/3 Enterprise Public Services

EA-RETAIL 110 0006 SAPKGPRA06 SAP R/3 Enterprise Retail

DIMP 471 0009 SAPKIPME09

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Oct 20, 2008 at 05:51 PM

    Hi,

    A few quick questions:

    1. Does this happen for all trees or a particular tree?

    2. What is the tree type you are trying this on?

    3. Did you try and create a Z tree and test?

    4. Did you try by putting some characters and saved with the radio button "on" for the second option "Allow only these Characters"?

    If the answers for the above are:

    1. all, 2. all tree type, 3. yes, 4. yes; then try this and see if it works.

    First go to the field where you want these characters to have an effect and in the attributes tab, click on the detail view button in front of the Conv. function field. Out there you will see a check box for "Exclude/Allow defined characters"; check that and save. Activate. Now try and enter the characters and save.

    If it works, fine, else buddy you should be looking for a note.

    Cheers...

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      You are correct, the second string works. It is the exclamation mark that is the problem. Just enter ! and it will vanish, anthing else before it and it sticks.

      The only other parallel I can think of is the # in BI, which holds a special significance. The same could be true for the ! mark in DMEE.

      I gues this note may hold the answer: [Note no: 734353|https://service.sap.com/sap/support/notes/734353]

      Interesting this.

      Cheers...

  • avatar image
    Former Member
    Oct 20, 2008 at 06:02 PM

    Thanks for the suggestion. I fiddled around with it and came up with a strange result. Here is the string of characters I wanted to exclude:

    !%&#*[]{}<>=:;/\|_"`~^

    This would not save no matter what I did. So I tried this string instead:

    %&#*[]{}<>=:;/\|_"`~^!

    I moved the exclamation point to the end and it stuck. Is that weird or what?

    Anyone have a possible explanation as to why this worked?

    Add comment
    10|10000 characters needed characters exceeded