Skip to Content
avatar image
Former Member

Display characters as # problem

Dear all,

When i upload data from R/3, i have seen #, instead of Turkish letters . In the related customising, i have set it as ALL_CAPITAL, however i am still facing this problem.

Any idea?

thanks.

jmq.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • Best Answer
    Oct 20, 2008 at 01:55 PM

    Hi ,

    I guess that # is a lowercase language character for Turkish letters. ALL_CAPITAL only works for language characters

    that are in uppercase and you must only enter ALL_CAPITAL in transaction RSKC.

    1. probably represents a character value that is not available in the BW code page therefore the system displays it as

    #. If your BW system and R/3 source system are UNICODE you should check in SM59 in both the BW system and

    the R/3 system that this option is enabled. If you don't have UNICODE then you will need to convert # to some

    value that BW does accept in a routine in the data flow. If you display the data in RSA3 in the source system

    you should be able to see what this value really is.

    Best Regards,

    Des.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2008 at 02:19 PM

    hi again,

    still i have problem as i have checked both systems ara unicode, and in rskc i have ALL_CAPITAL_PLUS_HEX ,

    still in both upper and lowercase letters i have # problem.

    what else can it be?

    thanks

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      If Turkish language is installed in the BW system??

      Also check if there is any routine at the transfer rules which is converting these kind of characters.

      Thanks

      Ajeet

  • avatar image
    Former Member
    Oct 20, 2008 at 02:03 PM

    Hi,

    Try this in RSKC

    ALL_CAPITAL_PLUS_HEX

    Thanks

    Ajeet

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2008 at 03:55 PM

    yes Turkish is installed in my system.

    As i told before, Turkish letters are not displayed properly.

    and i can see lowercase letters in texts as well. Is it normal? or should it capitilize all letters?

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 20, 2008 at 04:11 PM

    Hi Jmq,

    Lowercase letters are never allowed in BW. This is explained in the note 173241. However for the Infobject that you

    are loading the data too you can allow lowercase letters however this is not recommended. You can make this change if you

    goto EDIT mode for the infoobject in RSD1, you need to flag the option 'Lowercase letter' under the 'General' TAB to enable

    this, you will then get message at the bottom of the screen that explains the consequences of making this change. Have

    a look at the long text of the message.

    Best Regards,

    Des.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 21, 2008 at 05:50 AM

    So i have few questions:

    1) what should i do when i upload texts that is lowercase in r/3?

    2) still i have problem with uppercase Turkish letters even though i have all_capital or all_capital_plus_hex in rskc.

    thanks all for your help.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 02, 2009 at 05:10 PM

    thanks

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 07, 2009 at 12:10 PM

    Hi,

    Haven't solved that issue properly as i am still facing with #.

    If you solve this problem please let me know too..

    Thanks.

    Add comment
    10|10000 characters needed characters exceeded