Skip to Content

CRTD status allowed PO even after business restriction

Hi Experts,

I have restricted Material PO creation against WBS with system status CRTD for Material PO. In Fact it is working for me for service PO against WBS also.

I found that one service PO line item was saved against WBS with CRTD system status.

When I try to replicate the same I am not able to save PO service line for tat WBS as error pops up saying "system status CRTD is active"

After several such replication step suddenly system aloowed me to save one such service PO line item against such WBS.

Now, I am not able to raise service PO against such WBS anumore.

Isn't it somethind weird?

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Hi Guys,

    I am able to replicate this issue now. I created a service line item for a Released WBS and then I added line item for CRTD WBS and system accepted it.

    Whenever I create service PO line item as a first service line item for CRTD WBS system pops-up CRTD status error .

    Anyone observed this system behavior ever?

    Thanks.

  • Get RSS Feed

2 Answers

  • Apr 28 at 11:02 AM

    Hi Friends,

    Any insight on this pls?

    Thanks.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 29 at 07:47 AM

    Hi Saurabh,

    You have restricted this using Custom Logic against system status or you have User Status in place.

    As per your post, i understand its custom enhancement against CRTD status, in such case, you might missed the particular scenario to restrist it.Check with your abaper, they may need to enter the similar logic of code in some include.

    Regards

    Terence

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Maria,

      Thanks. Yes surely.

      While adding 2nd service line item and giving WBS element in account assignment, system is accepting it.

      But, whenever I create a service PO and add this WBS in its first service line item then it errors out as required.

      When I create another new PO and add first line item with a REL WBS then it accepts it as std. but when I add second service line item with CRTD WBS system accepts it too.

      This is what weird I m observing.

      Thanks & Regards

      Saurabh