Skip to Content
avatar image
Former Member

How to assign interfaces to Business System

Hi,

In PI 7.0 we can assign service interfaces to Business Systems in the Integration Directory. But in PI 7.1 it is not possible, as it seems the Integration Directory takes all data about the Business System from its configuration in the SLD itself? So how to specify the sender and receiver interfaces for a Business Systems in PI 7.1?

Thanks in advance,

Dipankar

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Oct 20, 2008 at 11:28 AM

    In PI 7.0 we can assign service interfaces to Business Systems in the Integration Directory.

    How were u doing this? I think this was only possible for Business Service and not for Business Systems.

    And in PI 7.0, service interfaces were being called as message interfaces. 😊

    Regards,

    Prateek

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Dipankar Saha

      HI Deepankar

      You need to add Product and software component in Technical system. Then you will get that as Service interfaces while configuring SLD.

      Now go to the Business Service and add Outbound and inbound service interfaces.

      Thanks

      Gaurav

  • avatar image
    Former Member
    Oct 21, 2008 at 04:20 AM

    Hi,

    Assign Software product to the technical system for your R3.

    After this go to your business system for your R3 and select the software component version.

    After this you will be able to use service interfaces of that software component version as a sender or receiver service interfaces for your business system.

    Regards,

    Sami.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2008 at 07:04 PM

    Here is what i do to get the Message interface names when using Business service.

    Double click on Business service->under the Receiver tab,add the outbound Message interface and under the sender tab,add the inbound message interface.save and activate your business service.Once this is done,you can see the message interface with business service in the same way as you see message interface with Business system.

    Thanx

    Aamir

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 21, 2008 at 08:25 AM

    Hi!

    See there are lot of differences in XI and PI and also between PI 7.0 and PI 7.1.

    Here in this case in XI after creating Business Systems or else Business Services you need to add both Outbound and interfaces even though you have added Software Component Version to the respective Business systems.

    But if you observe in PI 7.1 it will be activated automatically and no need of adding all those interfaces.

    Hence Kindly import those SLD components succesfully and also please activate those components and and check it once...

    Still if you are facing same problem go to Transaction Code: SXI_CACHE and do cache refresh so that it may be reflected by refreshing all the IR and ID objects.

    Also do ADapter cache refresh...refresh in same Transaction code...

    Or else if you are adminstrator go to TCode : SMICM and go to MEnu--> As JAva and --> Do j2EE soft Restart instead of Soft Restart...or else ask your basis poeple to do the same...

    Note: WHile doing J2EE engine restart please make sure any Transactions or else any one or working on PI because it may take 20-25 mins to become server up again ...

    I hope it will be useful to you in final case...

    Regards:

    Amar Srinivas Eli

    IF still if youa re facing same problem do J2EE Soft Restart

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Dipankar Saha

      Hi!

      Will you elaborate your question once and will you explain in detail the components and what entries corresponding entries in the SLD are not able to see and at where. so that I can try from My side

      Regards:

      Amar Srinivas Eli

  • Oct 21, 2008 at 12:05 PM

    Any idea which CR content is required or how to resolve this issue?

    Add comment
    10|10000 characters needed characters exceeded