Skip to Content
avatar image
Former Member

Can´t log on to SAP system in ABAP from Eclipse in MAC OS

Hello Experts,

I have an Eclipse Oxygen Installation on my MAC OSX machine and want to connect to SAP Gui.

I am able log in in the SAP Gui 7.50 independently, but not through Eclipse.

Please suggest a help for this error.

I get the Error Message:

Please contact your system administrator. A new version of SAP GUI for Java needs to be installed.
Actual Version * SAP GUI 7.50 rev 1, 075000040100, /Applications/SAP Clients/SAPGUI 7.50rev1/SAPGUI 7.50rev1.app
Required Version 072000040600.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    May 01 at 07:20 AM

    Thank you guys for all your time and details shared on this issue.

    It is been resolved now.

    I have changed the Java version from Java 9 to Java 8 and reinstall SAP Gui 7.5 again and it works perfectly now. Java version 9 should be removed completely from root system with all existing data to be flushed.

    I have also tried with Gui 7.4 but not fruitful, so what i understand is, for Mac OS the correct combination is Java 8 and Sap Gui 7.5.

    (Special help from Integration consultant Shashi Kant Nishad).

    Regards:

    Arya

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 27 at 08:53 PM
    -1

    Hello,

    I have heard of this problem before. Please refer to the comments in https://blogs.sap.com/2012/06/12/faqs-abap-development-tools-for-eclipse/

    Best regards

    Rolf-Martin

    Add comment
    10|10000 characters needed characters exceeded