Skip to Content
0

Compatibility JAVA 8 with BO 4.1

Apr 26 at 06:59 AM

136

avatar image

Hello,

We migrate the existing java version on the server to JAVA8, We would like to know is that BO 4.1 is compatible with this version, How to change the java version that BO uses,

Existing java :

  • Java : JVM Version: 6.1.066
  • Tomcat : Server version: Apache Tomcat/7.0.55

java-bo.jpg

Thank you in advance for your help,

Regards,

java-bo.jpg (75.7 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Yogesh Patel
Apr 26 at 01:59 PM
0

Hell Souhail ELMALIH,

If I am at your place I would start looking at link below...

https://support.sap.com/content/dam/launchpad/en_us/pam/pam-essentials/TIP/BI%20Platform/BI%20Platform%204.1/SAP%20BusinessObjects%20BI%204%201%20Supported%20Platforms%20(PAM).pdf

PAM link for this product is as below.

https://apps.support.sap.com/sap/support/pam?hash=s%3DSAP%2520BusinessObject%26o%3Dmost_viewed%257Cdesc%26st%3Dl%26rpp%3D20%26page%3D1%26pvnr%3D67837800100900006540%26pt%3Dt%257Co

As far SAP note : 2112338 - List of Bundled Tomcat and JVM versions shipped with each (support pack) SP of SAP BusinessObjects Business Intelligence 4.0/4.1/4.2

You need to upgrade your SAP BusinessObjects Business Intelligence platform support pack (If it is not on SP9 or SP10). Since you mentioned 4.1 only its difficult to say it will support java version or not.

I would prefer to upgrade SAP BusinessObjects Business Intelligence platform with new support pack which can lead in to less issues.

Hope this resolve your question.

Thank you

Yogesh

Share
10 |10000 characters needed characters left characters exceeded
Denis Konovalov
Apr 27 at 08:23 PM
0

1. you can't change Java that is used by BO
2. You can change java being used by tomcat. See PAM for supported versions of java and tomcat.

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Hello,

Our Objective : to make disappear from our servers the versions of Java prior to version 8, so for the version java used by BO - is it for technical reasons (this is not possible on the application side)? - will the application not work with another version? - is version 8 not maintained? (but it can work)


0

BOE servers use Java SAP provides. It is not supported/possible to change it outside of regular SAP maintenance process (upgrade to latest patch/SP).

0
if we want to migrate to a version that uses JAVA 8 we migrate to BI 4.1 SP6 or BO 4.2?

0
0
Manuel Garcia
Apr 26 at 08:51 AM
0

Hi,

For the List of Tomcat version and JVM version which are shipped with BI 4.x. for a given SAP BusinessObjects Service Pack see note 2112338.

Regards,

Manuel

Share
10 |10000 characters needed characters left characters exceeded
Manuel Garcia
Apr 26 at 09:18 AM
0

Checl also KBA 2504606

Share
10 |10000 characters needed characters left characters exceeded