Skip to Content
avatar image
Former Member

Disable first two rows in a table control

How to disable first two rows of a table control on a view?

Thanks

Sat

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 21, 2008 at 11:20 AM

    Hi,

    You have to do this at the table column cell editor level for the first two.

    Create a calculated attribute of type boolean code as follows

    Bind this attribute to the enabled property of individual cell editors.

    //@@end
      public boolean getEnabled(IPrivateExportTableDataCompView.IContextElement element)
      {
        //@@begin getEnabled
    	if(element.index() == 1 || element.index() == 2)
    		return false;
        return true;
        //@@end
      }
    
    
    

    Regards

    Ayyapparaj

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2008 at 04:11 AM

    Hi Sat,

    Select the table row and set the visible property as a blank.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2008 at 06:22 AM

    Hi,

    Please check the follwoing SDN forum discussion:

    Accessing Table Lead Selected Row elements

    disabling-a-row-of-table-at-runtime

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2008 at 11:46 AM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 21, 2008 at 11:33 AM

    Hi,

    create one extra attribute of boolean type where the attributes of the table are defined.

    and bind the attribute with enable property of the "table cell editor".

    while populating the values into the table set the boolean attribute value to false for first two rows and true for remaining rows.

    hope it helpful to you.

    Regards,

    ramesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2008 at 06:38 AM

    Hi,

    Go through the following threads, It is solved

    [Problem with Table?;

    [how-to-disable-a-row-in-a-table;

    Regards

    Raghu

    Add comment
    10|10000 characters needed characters exceeded