Skip to Content
avatar image
Former Member

Business Objects XI report timeout

Hi All,

I'm running a quite simple environment:

Windows 2003 R2 SP2

IIS 6

Oracle Database (remote on Linux but same subnet)

Business Objects Server XI R1 SP3.

I'm having an issue with reports getting time out errors after 2 minutes before they have had a chance to complete.

What I want to do is increase the setting that lets the report run before it errors. I can monitor my database and still see SQL being passed when the 2 minute limit is reached.

I have changed the 'Default Website Properties' Connection Timeout setting in IIS to 500 seconds and restarted, this has not helped the problem. I have looked through all the settings under Servers in the CMC, I can't see the right one. I'm not asking for the connecting setting before I need to log back in, I need the setting that will let a report run for 10 minutes before it errors.

If I run a problem report via Schedule, it completes but is very close to 2 minutes. If I run it On Demand, it times out after 2 minutes, but I can still see the query selecting data then gets terminated.

Thanks in advance, Jason.

Edited by: Glenn Rieger on Oct 20, 2008 2:52 AM

Edited by: Glenn Rieger on Oct 20, 2008 2:55 AM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 21, 2008 at 02:10 PM

    Hi;

    I think you want to check the properties for the Crystal Reports Processing Server in the CMC web app.

    Regards;

    Lionel

    Add comment
    10|10000 characters needed characters exceeded

    • Change the session timeout parameter ion the web.xml file which controls Infoview. Its inside D:\Program Files\Business Objects\Tomcat\webapps\businessobjects\WEB-INF for XI R2. There are many other posts for 3.0.

      This will make sure that sessions are not timedout forlonger running queries.

      Bye

  • avatar image
    Former Member
    Oct 20, 2008 at 05:16 AM

    Hi Glenn,

    Import the existing Universe

    and under File>Parameter > Control >Limit execution Time

    increase the time there ..

    Hope this would help you.

    Regards

    Prashant

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Prashant, Thanks for your message.

      I'm a little confused, thanks in advance for your patience. Far as the Universe goes, we may not be running one.

      We are creating reports in Crystal Reports Professional on XP, then uploading them to Infoview on Windows2003, IIS. They are then being run from Infoview via web browser on the XP client. This is where the timeout problem is happening. How can I change the time allowed to run a report from Infoview?

      I have changed the default website peoperties/connection time out to 1200 seconds and restarted, this has not helped.

      Thanks, Jason.