Skip to Content
avatar image
Former Member

Synch send from BPM

Hi all,

I have a synchronous send step to a webservice from my BPM.

I am getting the error com.sap.aii.af.ra.ms.api.DeliveryException: No response available. after 3 mins the call is made.

My webservice would take some time to response hence i would like to increase the timeout threshold. Any idea how how can i achieve this?

I have set the variable XMBWS.Timeout in Soap Adapter Module to be 10 mins however i am still getting that error in moni.

Appreciate any help.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Oct 18, 2008 at 05:46 PM

    Hi,

    I dont think increasing timeout will solve ur problem.

    Whenever u see this error,plz check if the target/receiver system is up

    and there r no issues with network connectivity.

    Thanks!

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 18, 2008 at 06:25 PM

    Hi

    After increasing the time out this should be solved. IF not then the problem is target system downtime or network and that you cannot control. At max you can schedule automated restart of failed messages

    1. IS_ENTRY - change the number of retries TUNING IS_RETRY_LIMIT

    2. A mass restart by scheduling RSXMB_RESTART_MESSAGES

    Thanks

    Gaurav

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 19, 2008 at 10:46 AM

    Hi all,

    What i meant was after i have set XMBWS.Timeout in Soap Receiver Adapter Module to be 10 mins, I am still getting the error in SXMB_MONI after 3 minutes the message was sent from PI to the SOAP Receiver.

    So are there any more settings to increase the timeout?

    There is absolutely no problem with the web service. It is just taking a much longer time to response.

    Appreciate any response.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 20, 2008 at 04:10 AM

    Hi all,

    I have solved the problem

    In Visual Admin, Under the service SAP XI Adapter: XI

    The time can be increase using this property.

    xiadapter.inbound.timeout.default

    Appreciate all helps.

    Add comment
    10|10000 characters needed characters exceeded