Skip to Content
avatar image
Former Member

RTF-Text from a Dataset is not formatted correctly

I'm programming with VB.Net 2008

I have a table with memofields where text is stored in the rtf-format.

If Crystal-Report accesses the data direct from a Memo-field of an ACCESS-Database all things work well. The text is correctly formatted in the report.

If I read the table into a Dataset and Crystal is accessing the data via this Dataset, the formatting doesn't work. I just get the pure text with the rtf-code-signs.

Does someone know this problem and has a workaround?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 17, 2008 at 08:00 PM

    Are you using Crystal 2008, or the free version that comes with VS2008 (which is a much older version)? If you are using the free version, have you upgraded to the service pack for it (CR Basic for VS 2008 Service Pack 1)?

    I use it with the full version (Crystal 2008), and it works just fine.

    https://www.sdn.sap.com/irj/sdn/businessobjects-downloads

    HTH

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank You for your answer, sorry that I answered so late.

      I'm working with Crystal XI and with free Version for Crystal for VS2008. I use the servicepack 1. In both versions I cannot succeed to have the rtf-text correctly formatted when I access the data via the Dataset.

  • Oct 22, 2008 at 11:08 PM

    Did you turn on rtf text interpretation for your database field? You can turn it on by going into the format options for the field and clicking the Paragraph tab. Then enable the RTF Text Interpretation.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      For sure I've done it, otherwise the report didn't work correctly when I accessed the data directly from the database. It is the same report I'm using I just changed the way the data where accessed from.

      Thank You