Skip to Content
author's profile photo Former Member
Former Member

Improve Triggering Time for outbound IDOCs

Hi,

We have a requirement where in we have to transfer some material master data from Production system to a Testing system.

We schedule a background job for BD10 in the Production system which generates IDOCs for the material data.

Similarly, after we get this IDOC in the Testing system, we run RBDAPP01 to process the IDOCs.

Now the problem is, the IDOCs are getting generated in the Production system quickly and we can see the status of the IDOCs as 03 which means IDOCs

are sent from the production system. But it takes too long for us to see the IDOC in the testing system.

( We sent some 50000 IDOCs from Production System and after 6 hours, we can see only 20,000 IDOCs in the Testing system. )

Any idea how we can reduce this time? Is there any background program scheduled for the IDOCs to be sent from one system to another, where in we can change the frequency ?

After changing the output mode in the partner profile from TRANSFER IDOC IMME to COLLECT IDOCS , and increasing the packet size, we see some improvement.

But can it be improved further?

Any pointers to this is highly appreciated.

Regards,

Suganya

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 17, 2008 at 07:05 AM

    Hi,

    I have one doubt in this that is " are you created background job scheduling for triggering the success ful idoc?.

    With Regards,

    Narasimha Rao.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 17, 2008 at 09:04 AM

    Hi,

    One thing you cand do is use the Parallem Proc option of the program RBDAPP01 This way the IDocs will be processsed parallelly instead of sequentially. Take a look at the documentation of the program for parallel proc. And remember with parallel processing, large packet sizes lowers the level of parallel processing.

    I hope you are specifying the the message type in the selection screen on the program RBDAPP01so that it processes only MATMAS messages.

    Hope this helps

    regards,

    Advait

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi ,

      Here the problem is not with RBDPPA01 , When you got 64 status code then u can execute this program. But here the idocs are successfull but it is taking time , that's right... check

      SM58 t.code also, if the idocs are queue...

      Thanks & Regards,

      Narasimha Rao.

  • author's profile photo Former Member
    Former Member
    Posted on Oct 17, 2008 at 03:13 PM

    ask your basis team to check and tune the tRFC queue. your tRFC queue is the bottleneck here

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.