Skip to Content

My Inbox: Error when mapping custom OData service in extension project

Apr 23 at 09:34 AM


avatar image

Hello Guys,

I am trying to extend My Inbox application. As such, I have redefined the Taskprocessing service and I activated it in using transaction /iwfnd/maint_service.

Now, when I create the UI5 extension project in Web IDE (extension of the CA_FIORI_INBOX app) and map it to the new OData service, I get this error message : 'Resource not found for the segment 'SAP__Origin'.'

This error coreesponds with this OSS Note: 2464981 - Extension of Custom My Inbox gives Error

In this note, the solution that is being proposed consists of adding a system alias to the service. But, I have already done this.

Did anyone encounter the same problem ? Any help will be greatly appreciated!

Best regards,


capture.png (26.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Leonardo Gomez
May 07 at 08:45 PM


My Inbox app has the particularity that supports multiple origins for its oData service. When you configure your app and set the data source, make sure you add the ";mo" after the service name and service version like this:

"uri": "/sap/opu/odata/iwpgw/TASKPROCESSING;v=0002;mo/"

This means that you are dealing with a multi origin service and SAP will automatically add a segment called SAP_Origin.



Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Leonardo,

Thanks for your response. It corresponds to the solution I have found. I confirm that it works.



saurabh vakil Apr 23 at 09:42 AM

Are you using an embedded gateway system?

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hello Saurabh, No, I have a separated Gateway and back end systems. I tried with the back end system as the service system alias but nothing has changed.


Please ensure that the Software Version for the backend system alias you use to register the OData service is /IWPGW/BWF and the For Local App flag is set.

Reference - SAP Fiori LL18 – System Aliases definition for Fiori


I have verified my configuration and it is conform with the one in the blog :(