Skip to Content

SAP WebIDE: Annotation Modeler Bug?

Hi there,

I'm facing the following error when tryong to open an newly created annotation file:

I followed this steps:

1) I created the destination like this:

2) I waited >5min and opened my project in WebIDE. I then added an oData service:

  • Right-click on project
  • new -> odata service
  • in wizard: "Service URL" --> "app_ssi_desi_sso"
  • I entered the relative URl "desi.xsodata" and clicked on test: Works fine. I can see views + their columns etc I have added to the service

3) Then I created the annotation file:

  • Again right-click on project
  • new -> annotation file
  • I entered name "Task" and chose the OData Service "desi.xsodata"

The odata interface worked so far. As I just wrote: I can see the services and with theor columns and datatypes etc... I can also access the odata service from my controller implementation and show the content in a table f.i.

BUT if I try to open the annotation file created in 3), I get the error message from the above mentioned screenshot.

I tried to debug the javascript source behind the scenes, and found out, that the destination is actually found, but in "config-reload.js" in function "getDestination", the URL comparison fails, but the destination IS correct.

I assume this is a bug in Annotation Modeler...?!

Any hints?

br,

Alex

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 25 at 12:29 PM

    Hi Christian,

    It seems that you configure the complete URL in the destination.

    For reference you can use this how to guide. https://www.sap.com/developer/tutorials/hcp-create-destination.html

    Please see Step 3: Confirm Data.

    Best regards

    Maruf

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 24 at 10:34 AM

    Hi Christian,

    I look into this issue. At the same time you could run your project against the mock data. Here is the link how you can configure it: https://help.sap.com/viewer/825270ffffe74d9f988a0f0066ad59f0/CF/en-US/a21e6bf74640413a8c7074f8922d8c3d.html

    Best regards

    Maruf

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 23 at 01:24 PM

    Mariana Naboka I saw that you answered a lot of questions regarding Annotation Modeler. Maybe you have an idea of what's going wrong.

    btw: using WebIDE Version: 170330

    Add comment
    10|10000 characters needed characters exceeded