Skip to Content
0

Cannot debug SQL scripts (hdbprocedure)

Apr 25 at 12:49 PM

43

avatar image
Former Member

Hello experts,

Actually I have the exact same issue as in thread https://archive.sap.com/discussions/thread/3599692.

I am following the same OPENSap course, and were not able to debug the procedure.

I tried to debug .procedure & .hdbprocedure files, tried the design time object & the run-time in the catalog, tried in HANA studio & in eclipse with HANA plug-ins - even installed another version of HANA studio to try there - but no use, I can't debug.

I have all privileges to the relevant schema and EXECUTE to DEBUG(SYS), and I have defined all the debug configurations. Plus I checked that the procedures run correctly when regularly called from SQL console.

My current situation is that the hdbstudio and the eclipse respond the same (was not like that all the way - the previous version of hdbstudio responded differently):

- for the .procedure file in the local workstation I cannot even create a debug configuration (getting error:"Procedure is not active or does not exist on the server").

- for the .hdbprocedure file in the local workstation I cannot toggle breakpoints (no double click no right click.. neither in developer no in debug perspectives)

- for both the .procedure & .hdbprocedure objects in the catalog I can create the configuration and toggle breakpoint but when I run the debug it signs each breakpoint with a red X with error: "catalog lookup failed: procedure _SYS_BIC. does not exist" (_SYS_BIC is the schema...). When I change to a wrong parameter in the debug I get the exception for the right line that fails so I know it runs the code with the configuration, just doesn't stop...

My hdbstudio version is 2.3.14 and the system is HANA 1 SP 12.


Would be very glad if someone could help me,

Omer

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers