Skip to Content

Java SP level linked to ABAP SP lavel ?

Hello

I installed a Java add-in to an existing ABAP ERP NW04 system.

Now I want to patch the JAVA stack upto the highest possible level. However I do not want to move-up the ABAP Support Package level (level 9)

Can I move JAVA stack up to most recent level (level 22) without patching the ABAP stack ?

Or are there restrictions / compatibility issues between the 2 stacks ?

Thanks

Jo

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 15, 2008 at 10:40 AM

    Hi,

    I suggest you to read following guide.

    check SAP NetWeaver 04 - Support Package Stack xx on SAP Service Marketplace at service.sap.com/instguidesnw04 -> operations.

    You can find the Support Package number used for the Stack in section "List of Required Support Package Levels and Names".

    regards,

    kaushal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Jo De Graeve

      Hello Jo,

      The SP guide is available at

      service.sap.com

      => tab "Release and Upgrade info"

      => tab "Installation and Upgrade guides"

      => open "SAP NetWeaver" (on the left)

      => open "SAP NetWeaver 2004"

      => click "Meantenance"

      You should find the guides for all SPS levels.

      It is best practice/recommended to keep ABAP and JAVA always on same SP level. (SP 09 of NW04 ABAP was released long time ago and should be patched anyway.)

      Whether different SP levels between ABAP and Java would work or not depends on how you would use each stack. For integrated solution which requires both stacks, it is better to keep them on same level.

      (I would upgrade ABAP and patch Java to the same level...)

      Best regards,

      Victor