Skip to Content
0

@sap/node-vsi: incompatible NODE_MODULE_VERSION 59 vs 57

Apr 25 at 09:42 AM

245

avatar image

I just updated my node.js version to 8.11.1 and now I have a lot of issues with the sap node modules.

The newest version of @sap/node-vsi (1.4.7) includes the binary for win32-x64-v8-6.2 (which is for 8.10+ as well as for 9.x), but it is compiled with NODE_MODULE_VERSION 59. Unfortunately, the LTS Version 8.x is on Version NODE_MODULE_VERSION 57 (see https://nodejs.org/en/download/releases/).


Result is that the app cannot start:

Error: The module 'node_modules\@sap\node-jwt\bin\win32-x64-v8-6.2\jwt.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 59. This version of Node.js requires
NODE_MODULE_VERSION 57. Please try re-compiling or re-installing
the module (for instance, using `npm rebuild` or `npm install`).

Unfortunately, I cannot re-compile the module (I have all build tools installed), because

gyp: binding.gyp not found (cwd: node_modules\@sap\node-vsi) while trying to load binding.gyp

So there is noo binding.gyp and also no source code which could be compiled.

Looking at some other modules, @sap/fibers comes with the necessary files, but @sap/node-jwt does not, too.

What is the supposed solution to this?

Should I stick to Node.js 8.9.4, which is the latest 6.1 V8 Version? Node 8.10+ will stay incompatible then?

Could you include the source files for all modules, this would make it possible to recompile at least?

Will you release an updated version for 8.10+ (which might be incompatible with Node 9.x then)?


Best Regards,

Fabian

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers