Skip to Content
avatar image
Former Member

LCM tool generates error "There is no VMS app object present in CMS"

Hello,

I have an issue with the new LCM tool with XI 3.1.

I am able to logon successfully to the Version Management application as I am an administrator but my colleagues are not. At first I thought this was a security issue but my colleagues have all rights assigned for the LCM application. Initially the users are able to login, and the issue happens only after Version Management is selected from the drop down box. The full text of the error is:

java.lang.IllegalStateException: There is no VMS app object present in CMS.

Any help will be appreciated.

Thanks!

Jason

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 16, 2008 at 01:33 PM

    Hello Jason,

    I'm assuming you gave your other users rights to the LCM in CMC->Applications.

    I don't see the VMS (it holds information concerning Subversion and how the LCM connects to it) there, to affect rights over that application. Administrators appear to have access rights.

    I'd recommend opening a SAP Incident to get clarification concerning rights to the VMS.

    Sincerely,

    Ted Ueda

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 07, 2008 at 05:59 AM

    Hi,

    In LCM v1, only the Administrators group has rights to use Version management.

    The rights granted by you on the LCM folder and application is for the "Promotion Jobs" workflow.

    so, no-administrator group users can create, edit, promote jobs only.

    this will be addressed, when LCM will have application rights created.

    - mahehswar

    Add comment
    10|10000 characters needed characters exceeded