Skip to Content

Unable to De-list some articles using WSM3 by giving "Valid to date" as today's date.

Hi Retail Experts,

Requesting you to help me in understanding the concept of De-listing using WSM3.

I want to De-list all the articles assigned to an assortment. So I used T code: WSM3 and gave the valid from and to dates as today date and executed.

I found some of the entries in WLK1 table were updated with valid to date as today. But some articles were still having the validity dates of 31.12.9999.

So, How to De-list them and why they are not De-listing as per the attached screenshot.


Sridhar Madiraju.

listing.png (85.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 24, 2018 at 06:20 AM

    Hi Sridhar,

    For discontinuation on merchandise level you can use WSE6.

    Just based on the screenshot you have provided I am not able to provide explanation, it would need more analysis.

    But delisting an article is realized by either setting the DATBI (Date to) to todays date - 1 (yesterday), or by setting the SSTAT="5" value.

    Both means, the article is delisted.

    Best regards,

    Add comment
    10|10000 characters needed characters exceeded

    • Did you uncheck the flag (which is set by default) for "Select By Mat. Listing Date"?

      If it was not unflagged, then the listing from/to dates are taken from the article master, and not from the selection screen of the listing transaction.

  • Apr 23, 2018 at 06:03 PM

    please use WSP3 versus WSM3 for article delisting.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Joseph,

      In this case, why some articles were updated with valid to date as today's date. when i used WSM3 and why for few others do i need to use this WSP3. That too this WSP3 is not assortment based.

      So if i want to delist all the articles from an assortment, do we have any other option other than WSM3?

      I tried using WSE4 by simply selecting the delete listing conditions and un-tick the test mode as shown in attached screenshot. But it also didn't worked for me.


      Sridhar Madiraju.

      wse4.png (29.2 kB)