Skip to Content
avatar image
Former Member

Missing Primary Index

Dear Experts,

We have missing index problem in one of our custom table (ZFBID). We tried to re-create through SE14 but it was failed, the index is still missing.

Prior to the missing index, ZFBID structure was changed and transported to QA and PRD, however it caused problem when doing in PRD, we have to restore it by recovering through db2 level, and now the primary index is missing.

How to re-create the index? Please give me the detail steps if using db2 level command.

Thank you in advance,

Rudi

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Oct 14, 2008 at 06:35 AM

    To provide help, I should know the error message received when the index is attempted to be created. There should be an SQL error reported. Look into the SYSLOG (transaction SM21) to see the error message. The SYSLOG should show you which work process received the error. If the SAP dev-Trace from that time is still available, it will contain the detailed error as well.

    Malte

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Rudi,

      I have simillar problem. However - my solution was:

      1. make copy of "damage" table; Z_AAA->Z_BBB
      2. delete "damage" table Z_AAA from transport and also in SE11
      3. run the FM: DB_DROP_TABLE in SE37, putting the "damage" table Z_AAA in TABNAME field and run.
      4. in transaction DB02 (or ST04), found entry "Alerts->Database Check", there was entry with "damage" table. I mark the entry and delete it.
      5. then make new copy of backup table with original name Z_BBB->Z_AAA
      6. delete unneeded table Z_BBB

      This was only solution which worked for me.

      Hope it will be useful for somebody.