Skip to Content

Integration Builder does not use Fully Qualified Domain Name

It appears that when I try to access the Integration Builder it does not use the fully qualified domain name, only the host name. This is not a problem for me, but is for our people off shore. Does anyone know of a way to change this so that it will use the FQDN? Thanks.

Jon

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Oct 13, 2008 at 03:19 PM

    R they using the same name in host file?

    thanks

    farooq

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 13, 2008 at 03:20 PM

    I believe the host file has the fully qualified domain name.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 13, 2008 at 04:15 PM

    As stated above, I already have an entry in my host file with the FQDN. I also have an entry with just the hostname. Is that extra entry causing the issue?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi

      For same IP address if you have more than one entry. This will create problem

      Most of the time I found the entry occurred first in host file always over right the other one.

      Thanks

      Gaurav

  • Oct 13, 2008 at 08:03 PM

    I'm sorry, but none of the above suggestions solved the problem. I removed the XI1 hostname from the host file and left only the FQDN and it is still the same result.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 14, 2008 at 04:14 AM
    Add comment
    10|10000 characters needed characters exceeded

  • Oct 14, 2008 at 07:29 PM

    I made the corrections stated in the note and changed the hostname entries in the Exchange Profile, but that did not solve the problem.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 14, 2008 at 08:44 PM

    This is solved now. I had to add the following profile parameter to the instance profile. icm\full_host_name

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      For the definitive answer on how FQHN are resolved in SAP check SAP Note 773830.

      The ICM sets the FQHN using the following hierarchy.

      1. The parameter SAPLOCALHOSTFULL in the SAP profile (recommended for high availability configurations) has the highest priority. If it is set in a profile file, the ICM uses this value as the FQHN. Note: the system default value of SAPLOCALHOSTFULL contains the host name without domain, so the system default is ignored by the ICM.

      2. If the parameter is not set, icm/host_name_full is analyzed.

      3. If this parameter is not set either, the ICM uses the FQHN of the operating system. For this reason, check the settings of the hosts file at the operating system level.

      Hope this helps 😊

      Michael