Skip to Content
avatar image
Former Member

Webi Report Server request timeout

Good day,

How do we configure requesttimeout of webi report server on a linux environment? is it via ccm.config?

BO Version: BOXI R2 SP3

OS: Red Hat Linux 2.9

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Oct 10, 2008 at 08:26 AM

    we're still getting this error. despite increasing the sessiontimeout (tomcat), requesttimeout (webireportserver), and cache size.

    would you have any idea how to get around this?

    30270: An internal error occurred while calling the 'processDPCommands' API. (Error 30270) BOException caught:RESULT=80004005;WHAT=RefreshBatch failed

    30567: Unable to save the document to the repository due to the following error: Failed to get EnterpriseError Interface (Error: WIS 30567)

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi;

      at this point, maybe you want to check that your Input and Output File Servers are up and running.

      Check their respective log files on the server.

      Regards;

      Lionel

  • avatar image
    Former Member
    Oct 09, 2008 at 02:06 PM

    In the CMC, servers section.

    Also, in XI3.0, the Webi Report Server is now called the Web Intelligence Processing Server.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 09, 2008 at 02:08 PM

    Hi;

    yes, as per documentaion, in ccm.config, on the WIReportServer command line:

    -requestTimeout N. Where N is in milliseconds, the default is 600,000 and lowest allowed value is 30,000. If it is expected that reports will run longer than 10 minutes when scheduled, then this setting should be increased.

    This is a low level time out, maybe you first want to check the Web Intelligence Report Server session time out in the Web Intelligence Report Server configuration pane in the CMC web application.

    Regards;

    Lionel

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Sorry. I misread your first post. Ithought you were on XI 3.0 and not SP3.

      The directory is (i think...I don't have an XI R2 env on Unix right now)

      <$INSTALLDIR>/bobje/tomcat/webapps/businessobjects/enterprise115/desktoplaunch/WEB-INF/

      Edited by: Srinivas Ganapathi on Oct 9, 2008 5:03 PM

  • avatar image
    Former Member
    Oct 09, 2008 at 02:35 PM

    Yes, this 20 mn is the key here.

    By default Infoview Session time outs and Webi Session time out are of 20mn, try to increase both.

    Lionel

    Add comment
    10|10000 characters needed characters exceeded