Skip to Content
avatar image
Former Member

New debugger doesn't stop at external breakpoints

I'm switched to the new debugger (using SAP Logon 7.10 PL10) and found out that the new debugger does not stop at external breakpoints in my BSP. When I switch back to the old debugger everything works fine, but the newer debugger is a lot more comfortable. I already searched the oss messages but didn't find any solution, so I just want to ask here before opening a new oss message.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Oct 09, 2008 at 03:08 PM

    Hi Michael,

    I think there is no general problem in using the new debugger for BSP-Applications

    since it's working fine for me.

    My experience is that the behavior of debugging BSP-Applications in not logical at all times. 😉

    Especially when you activate and deactivate a lot of breakpoints in one session.

    Sometimes it helps to delete all breakpoints and the debugging-settings in Utilities->Settings..., to logoff,

    to login again and make new settings. Close all browser sessions, too.

    You can also try the following:

    Go to transaction SICF, choose the BSP-Application you want to debug in the service-hierarchy and activate debugging in the menue Edit->Debugging->Activate Debugging...

    Then call your BSP again. The debugger should show up in the bsp handler class and you can go

    forward to your origin breakpoint.

    Best Regards,

    CW

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Michael,

      another hint: please check the number of open modes. In the most systems you are only allowed to open 4 modes. In case the maximum number of modes is reached, the new debugger is not able to open a new one...

      Regards,

      Uwe

  • avatar image
    Former Member
    Oct 09, 2008 at 10:32 AM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 09, 2008 at 11:09 AM

    Those links are about basic usage of debugging. Debugging with the classic debugger works fine for me...no problems at all. The problem I have is that I want to use the new debugger with BSP applications (for abap coding the new debugger is working too) and it doesn't stop at the breakpoints I set. For e.g. if I don't make any changes to the breakpoints I have...classic debugger works, new debugger doesn't even show up. So it must be a problem related to the new debugger?

    Add comment
    10|10000 characters needed characters exceeded