Skip to Content

Installing Eclipse with ADT on a Mac

Hello!

Seeing Eclipse with ADT on the Mac in open SAP course on ABAP Unit Test makes me wonder: Could any of you help me with the installation? I tried and failed (even after downgrading the JAVA, as required by Eclipse-installer :-().

Any help will be appreciated ;-)

Regards,
Vlad

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Apr 19, 2018 at 09:31 AM

    I haven't had any problems, but I never used any installer either.

    Installed latest JRE from Oracle, download Eclipse (Java or Web Dev edition), unzip, drag over to applications and .. er, that's it.

    You also need the SAP JavaGui installed - I'm running 7.5.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 20, 2018 at 06:41 AM

    OK I looked at your error message again and it's actually from the Eclipse installer, not from Eclipse itself. I am using JRE 1.8, straight download and install from java.com's default download page. As mentioned, I don't use the Eclipse installer either, just copy the package download to the applications folder.

    I noticed my Eclipses were taking up over 3GB so just for fun I deleted them all and did a reinstall. Download new one from https://www.eclipse.org/downloads/eclipse-packages/ (I chose the "Eclipse IDE for JavaScript and Web Developers", but also successfully used the Java and Modelling packages)

    Open DMG, drag over to applications, fired it up. The whole process took around 2.-3 minutes, it's downloading ADT as I write this.

    Edit: Another tip is to get SAPGUI working first as that's the more sensitive to the Jva environment. Eclipse just works once that's OK. You can get it from OSS.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 14 at 02:45 PM

    it is better not to use Eclipse on MAC, you will spend major part of yout time to solve non SAP problems, suc updat issue. SAP is not able to provide real product for Eclipse. each time even with small update you will see milions of problems. even it is RAM killer, Speed Enemy

    Add comment
    10|10000 characters needed characters exceeded

    • Huseyn, you must be right. I've had SO MUTCH TROUBLE that I cannot spend more time with it. I'd love to use it on a Mac but - as you said - there are so many problems and I'm not sure where to look first. Thanks anyway!

  • Apr 19, 2018 at 06:19 PM

    Solved!

    As mentioned here

    https://www.eclipse.org/forums/index.php/t/198527/

    the first error message is false and leads to a broken installment of Java :-(

    The solution is to install the newest Java, and not the JRE but the JDK (with Net Beans).

    After this Eclipse Oxygen 3 A installs as a charm. I'm to tired to install the SAP GUI, ADT etc. now, but I will tomorrow and report the results.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 19, 2018 at 07:18 PM

    I couldn't wait, so at least I installed ADT :-)

    Where can I find the SAP GUI for JAVA 7.5 for macOS?

    Add comment
    10|10000 characters needed characters exceeded