Skip to Content
0

SAP AS ABAP 7.51 SP2 – Developer Edition installation in Google Compute Engine FAILED

Apr 19 at 09:35 AM

62

avatar image
Former Member

#ABAP_Trial.

Dears

1. I followed the well written guide " Linux for Newbies: Installing ABAP AS on Oracle VirtualBox " by Julie Plummer, and completed a local VM installation perfectly. So, I did successfully install a ABAP AS 7.51 SP02 ASE version in my local machine.

2. After 1.) was done, I try to repeat the same work but my goal is to install the ABAP application server in a Google compute engine OpenSuSE VM. I have adopted Google's OpenSuse OS, the one for SAP, and I configured the Vmachine with static internal IP, as well as static external IP, also 128G HDD to have big enough installation space.
I had named the host name "ubasabap" with 8 characters, and I am very sure /etc/hosts have that entry. PING hostname is perfectly correct.

** Everything is almost the same as my local VM case, except for the IP addresses in Google Compute Engine setting, which is controlled by GCP.

3. Follow the previous used Guide, installed uuidd service, and make sure the uuidd service was running before I launching the install shell script - install.sh.

4. However, unfortunately, I failed to make the goal - have that same ABAP AS 7.51 on ASE running on a Google Compute Engine virtual machine.

5. I try to find out the problem by looking into the log file in /tmp, the log file sapinst.log. Since the log file size is 2.5MB, I cannot attach the log file with this message. But, I did find the follow error message in the bottom of this log file, I quoted as the followings:

"

INFO 2018-04-17 11:43:00.389 (root/sapinst) Authorizations set for /tmp/sapinst_instdir/NW73/SBC/STANDARD/sapcontrol.13.log.

INFO 2018-04-17 11:43:56.556 (root/sapinst) Copied file '/tmp/sapinst_instdir/NW73/SBC/STANDARD/sapcontrol.log' to '/tmp/sapinst_instdir/NW73/SBC/STANDARD/sapcontrol.14.log'.

INFO 2018-04-17 11:43:56.556 (root/sapinst) Authorizations set for /tmp/sapinst_instdir/NW73/SBC/STANDARD/sapcontrol.14.log.

ERROR 2018-04-17 11:43:56.616 (root/sapinst) id=nw.progress.startServiceFailed errno=CJS-30223 Could not start instance service of instance NPL/D00.

ERROR 2018-04-17 11:43:56.659 (root/sapinst) id=controller.stepExecuted errno=FCO-00011 The step StartInstanceService with step key |offlineadjustment_dialogs|ind|ind|ind|ind|0|0|start_instance_service|ind|ind|ind|ind|start_instance|0|StartInstanceService was executed with status ERROR ( Last error reported by the step: Could not start instance service of instance NPL/D00.).

INFO 2018-04-17 11:43:57.595 (root/sapinst) Creating file /tmp/sapinst_instdir/NW73/SBC/STANDARD/INSTANA.XML.

INFO 2018-04-17 11:43:57.684 (root/sapinst) Creating file /tmp/sapinst_instdir/NW73/SBC/STANDARD/instslana.xml.

INFO 2018-04-17 11:43:58.280 (root/sapinst) Working directory changed to /tmp/sapinst_instdir/NW73/SBC/STANDARD.

"

6. I also found the other error like message in /tmp, the log file "sapcontrol.log"

"

FAIL: NIEHOST_UNKNOWN, NiRawConnect failed in plugin_fopen()

"

But I have no idea what the message indicating ?

Google Search also failed to find useful information to guide me to solve the problem.

Can anyone kindly give me some lights to help to solve this failure ? since I failed to find any useful solution. Googling errno=CJS-30223 or Google errno=FCO-00011 is not helpful and no solution found yet.

So far, I can only guess the problem may be caused by Google Compute Engine Network IP configuration since it is the only area that is different from my local VM case.

Please help. Many thanks in advance.

Have anyone successfully install ABP AS 7.51 SP02 ASE version on Google Cloud Platform ??

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Apr 26 at 03:22 PM
0

Problem solved. Please close this case !

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Sorry but SCN is not police or help desk. It's not someone else's responsibility to "close the case". You've posted a question and you're the one who can close it.

Usually it's considered good manners to share a solution when closing the question. This could help others if they run into the same issue. If you don't plan to share such information then simply delete the question since it'll add no value to the Community without a solution.

Please see this blog for more information on what to do with the answered question.

1
Julie Plummer
May 07 at 09:55 AM
0

Hi Brian, Yi,

Like Jelena said:

This Community only works because people give up their time to help others. We offer this developer edition free, but we need your input.

Please please tell us - all of us - how you solved the issue (even if briefly) so that others can benefit in future.

Thanks and best wishes,

Julie.

Share
10 |10000 characters needed characters left characters exceeded