Skip to Content
avatar image
Former Member

Repost Function cannot be applied to multi provider in BW 7.5.

Hi Guru's..!

Hope you are all doing good..!

Recently my BW system upgraded from BW 7.3 to BW 7.5 version. When user are performing UAT activity in quality system, we are facing issue in BW-IP to one of planning function (Repost on Basis of Characteristic relationships) as below.

Error: Function cannot be applied to multiproviders.

Could you please provide your inputs to resolve this issue.

Thanks,

Venkat.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 24 at 01:26 PM

    Hi Venkat,

    Before SP9 (before system had Note 2066156), system had the program error that "No error message" as note title. "Function cannot be applied to MultiProviders" error was not shown though it should.

    After SP9 (after system had Note 2066156), the intended error message is then shown.

    If you would read the coding correction of this note, you would see that "i_r_msg->add_msg( )." was missing after "MESSAGE e131(rsplf) INTO l_dummy." before this note.
    The caused the intended error not to be shown.

    "A planning function of this type can only be created on an aggregation level that has been directly created on a planning-relevant InfoProvider (a simple aggregation level, see Aggregation Level).

    The aggregation level must contain all the InfoObjects of the InfoProvider that are valid in aggregation levels."

    See details here

    Best regards, Andras

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 18 at 08:26 PM

    Hi Venkat,

    All those functions that deal with char relationships I always implement on an aggregation level that sits directly on top of the provider.

    I think it makes sense, because each provider gets it´s own relationships and therfore a repost on top of a multi provider does not make a lot of sense.

    regards

    Cornelia

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Cornelia,

      Thanks for the replaying..!

      Earlier my system was in 3.5 version. At that time while creating repost function it was not encountered any error or warning. After migrated to higher version it is showing now.

      Thanks,

      Venkat.