Skip to Content
author's profile photo Former Member
Former Member

Help: N authorization to start service sap.com/pcui_gp~xssutils/XssMenu

Hi,

We are trying to configure ESS in our NetWeaver 2004s Portal. On the ECC backend system, we have added the SAP_ESSUSER_ERP role to the users. When the users logon to the Portal and access the Overview page, they get the error: "You do not have the authorization to start service sap.com/pcui_gp~xssutils/XssMenu."

Based on my search in the forums so far, I understand that this error might possibly have something to do with permissions with WebDynpro related services on the Portal, but have no idea on how the permissions can be given?

Questions:

1. how do we assign WebDynpro service permission on the Portal?

2. do we need to configure any WebDynpro services at the ECC backend system?

Based on the defaultTrace.trc on the Portal, I doubt there is anything that we need to setup in ECC backend since the first few lines of the error refer to what I assume is a Portal component:

"Date : 10/02/2008

Time : 20:11:18:982

Message : You do not have the authorization to start service sap.com/pcui_gp~xssutils/XssMenu.

[EXCEPTION]

com.sap.pcuigp.xssfpm.java.FPMRuntimeException: You do not have the authorization to start service sap.com/pcui_gp~xssutils/XssMenu.

at com.sap.pcuigp.xssfpm.java.MessageManager.raiseException(MessageManager.java:111)

at "

Any help would be greatly appreciated!

Many thanks in advance.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 03, 2008 at 07:30 AM

    Try to provide End user permissions (by assigning Eu_group) to the End User content folder in Portal Content.

    Make sure to check the box corresponding to end-user and assign read permissions.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Our BASIS person was not able to assign the created role to our user. Role assignments are typically done through Solution Manager. However, the created role does not seem to appear on the Solution Manager. In any case, this has gone to the BASIS for further investigations. Once S_SERVICE is assigned, I truly believe that the users should be able to access the relevant Business Package content. Thanks again Anil.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.