Skip to Content
avatar image
Former Member

Transport (STMS) issue + Hang

Hi,

From last two days we are facing issue with transport management system. There are two transport sitting in queue and not getting imported. Every time transport process run. It some how remain in the active state and never does anything. we tried to troubleshoot this issue and found that there is 1 record sitting in table trbat which should not be there.

. Also, there may be some other problem which needs to be fixed in order to TMS system work properly.

I have run se16> trbat>enter>execute>it display

Table: TRBAT

Displayed fields: 9 of 10 Fixed columns: 2 List width 0250

TRKORR FUNCTION RETCODE TIMESTMP CLIENT LANGU VARIANT ARGUMENT LOGNAME

HEADER P F 20080908090346 :D:T:S:tmp:F:P080908.C2Q

(Is it neccesary to delete this if yes can u tell me how to delete this?)

I click on table enetry but delete button is inactive

So, Pl. look into it urgently and do the needful as this is causing business issue.

Regards

mohsin mulani

Edited by: mohsin mulani on Oct 2, 2008 2:26 AM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Oct 02, 2008 at 04:04 AM

    Hi,

    You need to do the following checks and then proceed accordingly:

    1. Check the transport logs under transport directory for the above

    long running requests (/usr/sap/trans/log or /usr/sap/trans/tmp).

    2. Check whether Transport routes are configured properly, using STMS transaction. Also, perform the connection test, tp tool and RFC connections.

    3. Execute RSTPTEST program to check the STMS configuration.

    To clear the inconsistency and long running tp process , proceed as below.

    i. verify whether any tp is running at OS level. kill all the tp

    process which is running at the OS level (Ensure there is no transport done during this time).

    ii. Move all the files from /usr/sap/trans/tmp to some temporary

    backup directory.

    iii. Go to STMS -> import overview -> go to ->import monitor and

    delete the old entries.

    Then review the SAP Note 690449 for any .LOB file that is locking the tp.

    Please award points if helpful.

    Thanks, Dibya

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Dibya

      thanks lot my problem has been solved

      tail SLOG0837.C2Q

      WARNING: /usr/sap/crmtrans/tmp/ALOG0837.C2Q.LOC is already in use (80920), I'm waiting 5 sec (20080911044415). My name: pid 4743368 on plaixlp

      s116 (c2qadm)

      renamed the file ALOG0837.C2Q.LOC to ALOG0837.C2Q.LOC .old

      also cleared old tp files

      This automatically cleared teh entry of TRBAT also