Skip to Content
avatar image
Former Member

BEX Broadcast query to portal - force variable screen to show

When we publish a query to the portal, we would like to show the variable screen as the default screen. We can accomplish this by manually change the query string to include VARIABLE_SCREEN=X in the iView. We tried to change the web template - 0BROADCASTING_TEMPLATE as outlined in Note 643464 (even though that note is for version 3.5) to include this string during publishing. It's not working.

We are on Netweaver 7.0 (SP16).

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Oct 02, 2008 at 02:45 PM

    We are not using WAD. We are publishing query from BEX Analyzer to Portal through broadcasting.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Ok,

      just tested it, and this seems to work.

      The variable screen pops up when previewing the iview.

      But I must mention I have an obligatory variable in my query. Maybe that's a solution?

  • avatar image
    Former Member
    Oct 02, 2008 at 08:22 AM

    Hi,

    You are using WAD, in the Properties of the Web Template, you have an option for "Display Variable Screen" or "Force Variable Screen Display". Check it.

    So at any case the variable screen will be shown.

    0BROADCASTING_TEMPLATE is used in WAD 3.5.

    0QUERY_TEMPLATE_BROADCASTING70 or 0REPORT_TEMPLATE_BROADCASTING

    the above 2 templates are in WAD 7.0

    just try changing the Property of the Web Template as i have mentioned above.

    Hope this solves your issue.

    Add comment
    10|10000 characters needed characters exceeded