Skip to Content
0

Fiori Launchpad login

Apr 16 at 03:56 PM

119

avatar image

I upgraded BI 4.2 SP3 to 4.2 SP5. I see the login screen but after I enter my logon credentials > hit the login button, the login screen comes back with no errors.

https://<lb url>/BOE/BILaunchpad

In CMC, Restful WS > properties its set to: https://<LB url>/biprws and this URL works fine in the browser.

RWS is deployed on the tomcat server.

Any idea? Thanks!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Bharath B N
Apr 16 at 05:10 PM
3

Hi Roopa,

  • Check browser console if any errors - share the screenshot.
  • Check Network in browser - see the status of this API call - https://<LB url>/biprws/v1/logon/token. - share the screen shot
  • Login to classic BI Launchpad (https://<lb url>/BOE/BI) and then open new tab in same browser and Open fiori BI Launchpad (https://<lb url>/BOE/BILaunchpad) - because both the BI Launchpads share the same session.
  • Please check in CMC -> Applications -> BI Launchpad -> User Security -> Assign Security -> Advanced -> Add/Remove Rights

Bharath


Share
10 |10000 characters needed characters left characters exceeded
Roopa Puranik Apr 16 at 05:07 PM
0

Yogesh, Upon looking into this further we found out that Admin group did not have full control rights. Issue resolved!!

Share
10 |10000 characters needed characters left characters exceeded
Yogesh Patel
Apr 16 at 04:23 PM
0

Hello Roopa Puranik,

What if you initially login with URL : http://host:port/BOE/BI

As soon as you login to it try opening URL http://host:port/BOE/BILaunchpad - on new tab using same browser and see the results.

Thank you

Yogesh

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Yogesh,

I tried what you suggested and I am getting this, interesting!!

User has no rights to login to New BI Launchpad. Please contact administrator.

I tried logging in using administrator ID/PWD Ent authentication and I get the logon screen back with no errors.

Thanks, Roopa

1
1
Roopa Puranik Apr 18 at 08:49 PM
0

Do you guys know why I would be getting :capture.png

"Failed to get folders listing" error when I click on logout on BILaunchpad interactive viewer?

We are on BI 4.2 SP5 P100.

Thanks, Roopa


capture.png (2.4 kB)
Share
10 |10000 characters needed characters left characters exceeded
Bharath B N
Apr 20 at 11:14 AM
0

Check the browser network - any biprws API giving status code other than 200.

Show 6 Share
10 |10000 characters needed characters left characters exceeded

Hi Bharath,

See attached fiddler log. I see 404 error.

fiddler-log.png

Thanks

fiddler-log.png (146.6 kB)
0

Hi Roopa,

This is .properties file and wont cause any issues.

Please check if any REST calls giving error code.

API looks like: https://*****/biprws/*********

-

Bharath

0

Hi Bharath,

In the fiddler I don't see any thing related to biprws at the time I get the error. I checked the logs on tomcat and BOE server and I don't see anything related to biprws. Is this where you wanted me to look?

Thanks

0

yes. But as per the message you are getting there must be some backend call errors (biprws).

0

I would think so but I don't see errors related to biprws. And what I noticed is, if I keep trying to login and logoff after few tries I dont see the error but it again pops up!

The error is weird ""Failed to get folders listing" at the time of logout. I see this issue in our DEV environment too.

We are on BI 42 SP5 P100, P200.

1

Just a try. :(

Please clear browser cache and try . OR please try same in private mode of browser.

0