Skip to Content
avatar image
Former Member

wsdl publish in xi 3.0

Hello,

I created a wsdl over the soap sender channel in the ID.

It works fine with XMLSPY and SOAPSONAR.

The problem is we have to import the wsdl to the CE over URL. When a request to the wsdl URL is started we get an error about the content type. Instead the content type text/xml we get the content type text/html.

Is there a way to publish a wsdl at the xi 3.0 with the content type text/xml?

THX Regards Johann

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Sep 30, 2008 at 08:05 AM

    Hi,

    The problem is we have to import the wsdl to the CE over URL

    Are you refering to SAP Composition Enviorment as CE? How are you planning PI in this ? Can you elaborate the PI use and your scenario.

    Pls correct me if i am wrong.

    Regards,

    Anirban

    Edited by: Anirban Ghatak on Sep 30, 2008 4:07 AM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Johann,

      What is the URL you are using currently to get the WSDL? As far as I know, there is no standard way for publishing a WSDL in XI ( you dont have standard UDDI shipped with XI 3.0) It is a standard in PI 7.1 though.

      There are a couple of blogs by Naveen in SDN addressing this limitation using work arounds. You basically need to add/edit some entries in VA for this. Check the blogs, you will get a better idea.

      Are you following the same methods specified in the blog?

      Thanks

      Jaishankar