Skip to Content

Alerts

Hi,

I am triggering alerts in PI for any Adapter related errors. But when using a file adapter when a message is not well-formed, the adapter goes to error status. The messages are sent to the Alert Inbox every 60 seconds which is nothing but the polling interval of the adapter. Till the file is removed and the status of the adapter changes to u2018Activeu2019, the messages are continuously being sent. Is there any way to ensure that the message is only sent once?

Regards,

Pragathi.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Sep 29, 2008 at 04:43 PM

    what is the error you are getting in the file adapter? Is it some content conversion error?

    If yes, then you will have to use the option Archive Fault Files in the faulty files folder option in the sender file adapter.

    This would move the file to the archive folder and thereby the file will not be polled again and hence no repeated alert would be triggered.

    Regards

    Bhavesh

    Add comment
    10|10000 characters needed characters exceeded

    • Sorry Bhavesh,this is not content conversion error but one of custom module is causing this problem....the archive fault files dint work for this.....

      Regards

      Pragathi.

  • avatar image
    Former Member
    Sep 29, 2008 at 06:53 PM

    hi,

    please check the check box for Supress multiplealerts in RWB.

    Thanks,

    Madhav

    <removed_by_moderator>

    Read the Rules of Engagement

    Edited by: Juan Reyes on Sep 30, 2008 11:23 AM

    Add comment
    10|10000 characters needed characters exceeded