Skip to Content

IoT: My IoT MMS Device Management got deleted and now not able to create new Message Type

Hi All,

Suddenly I have noticed my IoT MMS service Device management got deleted from IoT cockpit.

And now when I'm trying to create a new set of Message Type in Device Management it's not allowing me.

Its saying "No data types found. You cannot create message fields without a data type.".

Can anyone please put some light on it.

mms.jpg (65.9 kB)
message-type.jpg (49.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Hi Anton,

    Thanks for replying!

    I'm using Trail account.

    You are correct, my device type and message type was there, now I cannot see them.

    And also I'm not able to create new message type.

    Its saying "No data types found. You cannot create message fields without a data type.".

  • Would it be possible for you to share your account ID, so that we could check the remote logs (within the next European working hours)? If you do not want to share it publicly, you may drop me a mail. Please find my e-mail address in my profile description.

  • Hi Anton,

    I have emailed my account ID.

    Thank you!

  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 16 at 01:29 PM

    Since you have your "rdms" destination in place with the correct settings and you claim you have recently modified your IdP settings, I could suggest the following workaround here:

    1. Open SAP Cloud Platform Cockpit
    2. Go to the Trust tab
    3. Change the configuration type to "Custom"
    4. Press the "Generate Key Pair"
    5. Save the configuration
    6. Press Edit again
    7. Select the "Default" configuration type
    8. Save the configuration.
    9. Try to access IoT Cockpit afterwards
    Add comment
    10|10000 characters needed characters exceeded

  • Apr 14 at 07:45 PM

    I have just checked the logs and see that your IoT Cockpit is not able to authenticate itself agains IoT RDMS (and retrieve supported data types - this is what error message on the screenshot says). Did you recently played with the Trust Settings / IdP configuration in your account?

    Lets try to check it step-by-step. The first point to check is the IoT RDMS HTTP destination.

    In your SAP Cloud Platform Cockpit go to "Applications" > "Subscriptions" > "iotcockpit" > "Destinations" > rdms

    Do you have a destination called "rdms" there? If yes, then check its properties:

    It should be of type "HTTP", its URL ends with "../com.sap.iotservices.dms/api", proxy type is set to "Internet" and Authentication is "ApptoAppSSO", additional property "TrustAll" is set to true.

    Adapt if some of the properties are wrong. Try to open IoT Cockpit from a new browser session and check if you still get an error message when trying to create a Message Type.

    Add comment
    10|10000 characters needed characters exceeded