Skip to Content

SAP Cloud Platform SDK stop working after latest Xcode update

Hi everybody!

Did you guys installed latest Xcode 9.3 from Apple and tried to compile your projects with SAP Cloud Platform SDK components? I did... And got

Module compiled with Swift 4.0.2 cannot be imported in Swift 4.1

import SAPFoundation 
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Apr 12 at 08:46 PM

    Valery Semichev

    There is a new build/patch available at SAP Store that is compatible with Xcode 9.3. You should download SAP Cloud Platform SDK for iOS (Xcode 9.3) 2.0 SP01 PL05

    Regards

    JK

    PS: With same patch you can work on Xcode 9.4 beta too.

    Add comment
    10|10000 characters needed characters exceeded

    • Thank you, Jitendra! You saved my work!

      The updated version works fine. Just to mention for others that it will be required to remove and re-add SDK Components into your Embedded Binaries Xcode section, as well as clean up after that.