Skip to Content
1

[BUG] Mission Avid Solver is not syncronized with accepted answers!

Apr 12 at 04:36 PM

98

avatar image

Today I have number of notifications about accepted answers. But the mission counter is still the same - 50% (5 accepted answers). Is it a stupid overnight batch job?????

P.S. Even fresh accepted answer is not counted!

10 |10000 characters needed characters left characters exceeded

Vadim, language. ;)

Calling Caroleigh Deneen to the rescue.

0

"Vadim, language. ;)" - Sorry, but I am absolutely frustrated how the system is working!

0

I can tell. Nontheless the missions just started. No need to shower them with 2 years worth of cumulated frustrations with the new Community platform.

EDIT: English is hard...

2

Sorry again, but starting with a non working engine is something I am unable to understand!

1

I can confirm same issue. 3 accepted answers and progress at 20%.

0

Sorry guys, micro service is busy with my updates, SAP missed to implement a macro service for me

2

Looks like the concept of independent services is not working!

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Caroleigh Deneen
Apr 12 at 05:14 PM
1

Hi Vadim, Sorry for the frustration.

Usually, the push to the mission service is just about real-time, but the gamification queue got flooded unexpectedly. We've been investigating what happened. It seems to be related to the same issue that caused the inundation of profile updates on the activity stream (https://answers.sap.com/articles/470796/profile-photo-update-proliferation.html). That was a bug that has since been resolved and should not happen again.

We are watching the gamificaition service logs and can see the queue is gradually going down, with activities being pushed and updating the mission progress. It may take several hours still to get caught up. We will keep watching and checking while the queue empties.

Mirko Friedrich

Show 8 Share
10 |10000 characters needed characters left characters exceeded

Still no changes!

0

4 hours - no changes!

0

Hi Vadim,

Thank you for the updates.

I checked again and I see 60% on Avid Solver in the gamification service now (logged at about 6:15 EST). You can check again on your My Missions page and let me know.

I cannot tell how far it's made it through the queue, however. I see two accepts for you answers today, so it appears the second has not made it's way yet, based on when you reported this.

0

Thank you!

I can see 60% now... But synchronization time is definitely not acceptable. Something is wrong with the engine...

0

It probably has not completed the job yet. I recalculated the progress and it is about 30 hours behind, accepted answers till around 5 pm CET of April 11 are included right now

0

Looks like some mechanical counters are used :)

0

There is also an issue with displaying the newly earned badges in the profile. So although earned badges and progress are reflected in the My Missions page (once they clear the queue that is) the badge is not displayed as expected in the profile. We have ticket opened and are working to resolve.

0

Vadim, the queue has been fully emptied now and mission progress should be reflected accordingly.

While most of the queue was pushed to the gamification service already last week, there was a set of outstanding activities that needed special attention and they only finished late yesterday.

Thank you for your patience while this was resolved.

1