Skip to Content
avatar image
Former Member

Crystal Reports XI release 2 SP2 won't load in Vista but OK in XP

Description:

Stopped working

Problem signature:

Problem Event Name: APPCRASH

Application Name ABC.exe

Application Version: 1.0.0.0

Application Timestamp: 487ed6c1

Fault Module Name: unknown

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 00000000

Exception Code: c0000005

Exception Offset: 050e3ed0

OS Version: 6.0.6000.2.0.0.256.6

Locale ID: 3081

This happens (only in Vista) whether the report is sent direct to the printer or to the Crystal Report Viewer and occurs at the crReport.Load (direct print) or New CrystalDecisions.CrystalReports.Engine.ReportDocument (viewer) statements.

After searing on web site, I came to know that we have to use, newer version 11.5.10.1298 merge module help to resole this problems, I want to know which version to download.

If any one has any better idea, Let us know. Our Clients are waiting for this.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Sep 25, 2008 at 02:44 PM

    Hi Lakshmi,

    Its a known issue with vista we have a workaround.

    Please try with this:

    Run a command prompt as administrator. From the start menu, select "All Programs", then "Accessories" and right-click on the "Command Prompt" shortcut and choose "Run As Administrator". From here you can use the following command to disable Data Execution Prevention (DEP) with the following command:

    bcdedit.exe /set nx AlwaysOff Keeping your command prompt open, run your setup or other process being stopped by DEP. Then, to turn it back on again, do the same and run the following: bcdedit.exe /set nx AlwaysOn

    Hope that helps,

    Regards,

    Shweta

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 25, 2008 at 03:01 PM

    We tried this on clients place, It did not work

    Disabling DEP on Vista:

    1. Click Start

    2. Click All Programs

    3. Click Accessories

    4. Right Click on Command Prompt

    5. Left click on Run as Administrator

    6. Click the Allow button if it asks you for permission

    7. Type or copy and paste this into the command prompt window:

    bcdedit.exe /set nx AlwaysOff

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi

      It tool while to answer the question, we were trying to to test on client mechine. I have used SP4 to resolve this issue.

      Thanks to every one.

      Lakshmi