Skip to Content
avatar image
Former Member

Accounting integration of cProjects 4.5 with ECC 6. No costing data exists.

Accounting integration of cProjects 4.5 with ECC 6.

Problem: On the accounting tab > costing view when we click u201Ccalculateu201D message u201Cno costing data existsu201D is produced.

I would be grateful for any advice on this issue.

The steps followed so far are:

Defined project type.

Activated for accounting integration as of flagged for transfer.

Object link (0FIN_INT_ERP_PS) u2013 standard settings are unchanged.

Project type linked to 0FIN_INT_ERP_PS with frame 09. No costing flag is not ticked.

Cost rate is defined for the org unit associated with the project and validity dates are wide enough for task.

Cost rates replicated to erp system (NONE) as cProjects and r3 are on the same system.

New project type has been replicated to r3 system.

Settings made in the r3 system:

Controlling scenario created. This has ps costing variant PS06. This will be used for ecp on the ps project after transfer has happened?

Project type has been associated with u201Cmulti level controlling (structure element, manual)u201D and the controlling scenario above.

Settings for ecp; has the controlling scenario above with costing variant PADH. The controlling area is the same as the controlling area on the org unit assigned to the project. This costing variant is used for pre calculation of plan costs i.e. before transfer.

Cost element and activity type have been specified for the project org unit and without and org unit.

Assign cost elements and activity types: The activity type has been planned with a price in the current year on the same cost centre that is the master cost centre on the organisational unit attached to the project.

NB The rate does default into the task from the task type and there is work specified for the task.

Thanks in advance,

Steve

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Sep 24, 2008 at 01:04 PM

    Hi,

    Please follow the steps as below:

    -> In the define project type setting check if the accounting integration is chosen

    -> Under Connection to External settings -> Activate accounting integration

    -> Define Object links for Accounting Integration: choose as per your requirement and set up the destination of the financial system

    -> Make general settings -> choose for the particular project type -> Use cost/revnue rate from cProjects

    -> do replication of cost/revenue rates

    -> do replication of prject types

    -> make settings in ERP system: here you connect to the financial system and define the controlling scenario and after that you choose either multilevel controlling or internal order

    Now you are ready to do the accounting integration in cProjects

    Upon entering cProjects and completing all the project definition related details, go to "Resources" tab and define the role type and assign a cost revenue rate that you have defined in the backend. Staff it. Again, you can do either role based costing or task based costing. This you would have chosen in the financial system. First release the project and then choose "Flag for transfer". Go to the accounting tab. Now click on calculate. You should see the costing done. Let me know how it goes and we would take it from there.

    best regards

    anantharam

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello, thanks for your reply,

      The rate does default into the Resources > Costing tab based on the created role. The error messages are as stated above.

      Best Regards,

      Steve

  • avatar image
    Former Member
    Oct 21, 2008 at 10:15 AM

    Hi Steve,

    did you get to solve this? I have the same problem. All settings seem OK, I even get the structure replicated, but no costs get calculated in cProjects.

    Thank you, L.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 30, 2008 at 08:38 AM

    even i am facing the same problem ( warning message "No costing data exists ) and the automatic creation of WBS doesn't happen.

    Any Clues??

    Regards,

    Jatin

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 30, 2008 at 10:38 AM

    What helped me solve this was configuring in ECC the ECP costing variant (Tcode IKKZ) using PADH as sample. Then you assign the new created one or PADH itself and it should work.

    Cheers, L.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      In my case I am using the cost variant PADH, copied it also and used the new one still the same message.

      I have defined the Controlling scenario as "Multilevel Controlling ( Project Role , Automatic )" for my project type but the WBS elements are not getting created in PS and I get a warning message "No costing data exists" on saving the project and on clicking the Account assignment button on Account integration tab i get the option only to assign the WBS elements manually.

      1. Created a new project of the same type.

      2. Assigned org unit on the additional data tab.

      3. Created a role.

      4. Assigned cost/Revenue rate.

      5. Saved ( as Type of transfer is maintained as "Automatic as of saving").

      Best regards,

      Jatin

      Edited by: Jatin Grover on Oct 30, 2008 1:53 PM