Skip to Content
avatar image
Former Member

Infoview - Could not get page number

I am using BO XI R2 Service pack 4 which is installed on Window server. When I try to open a saved report (infoview),it throws up an error as follows:

Could not get the page number-Error RWI 00223 (Error: INF).

When I use modify function on the saved report. The data is displayed perfectly.

Can you please help me to fix the problem?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Sep 23, 2008 at 09:09 PM

    Hi,

    Request you to provide me with the following information:

    1) Version of Business Objects (with Service Pack if any)

    2) Have you applied any hot fixes/patches on your deployment? If yes, then please specify the patches/hot fixes installed.

    3) Is this occurring with one report only or every WebI report ? If with one report only, please send a copy of the report (without any refresh on open).

    4) Please try Stopping & restarting the WebI Report Server check if it has any effect?

    5) Server Operating System Details

    6) Web-Server & Application Server.

    Looking forward for a feedback from your side.

    Regards,

    Deepti Bajpai

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 23, 2008 at 09:11 PM

    Hi,

    If you are using tomcat:

    Firstly Please try changing the Heap value in Tomcat 5.x.

    Please undertake the following steps to change the webi.propertie file :

    1.Program Files\ Tomcat\Logs\webapps\businessobjects\enterprise115\desktoplaunch\WEB-INF\classes\webi.properties

    2.Add the following line, if the line is not in the file, or comment it out and update the value as follows:

    MAX_HEAP_SIZE=<java_heap_size_for_app_server>

    The value <java_heap_size_for_app_server> represents the number of bytes and must match the value set to in the application server. For example:

    MAX_HEAP_SIZE=750000000 if you want to set 750MB

    3. Save the file, and restart the application server.

    Secondly for changing the same in Apache tomcat

    1.Click on Start

    2.Goto program files

    3.Tomcat\ Tomcat configuration

    4.Please click on the 'Java' tab, set the following values accordingly:

    u2022 Initial memory pool - The initial amount of memory you wish to have allocated to Tomcat for processing Java requests.

    u2022 Maximum memory pool - The maximum memory you wish to allocate to Tomcat for processing Java.

    Please make sure the changes made to webi.propertie file and in apache tomcat the size should be same for e.g.750 MB

    Regards,

    Deepti B

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      You can also try the following in case of JAVA Application Server:

      The storage token settings need to be modified for the WebIntelligence documents in the Java application.

      1. Open the webi.properties file from the application server. It is found here:

      /AppServer_DIR/businessobjects/enterprise115/desktoplaunch/WEB-INF/classes.

      2. At the bottom of the file, add the following parameters:

      WID_FAILOVER_SIZE=10

      WID_STORAGE_TOKEN_STACK_SIZE=0

      3. Restart the application server.

      This will give you ten document state tokens to keep in memory so they are available and any additional token requests will be stored on disk.

      Regards,

      Ekta Srivastava