Skip to Content
0

Crystal Server - Dynamic Parameter not working

Apr 11 at 05:57 PM

19

avatar image

Hello,

We are currently evaluating (and plan on purchasing) SAP Crystal Server 2016 along with SAP Crystal Reports 2016. Yesterday, I created a report in Crystal Reports and published it on Crystal Server, where users can run it from their BI Launch Pad. One of the reports that have been built have dynamic parameters. The first report with a dynamic parameter works as expected, however, subsequent reports published are not showing dynamic values and require the end-user to key in the values.

All reports have been built and published in the same way, so I'm unsure as to why this isn't working.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Scott Shelton Apr 11 at 07:53 PM
0

I found our resolution to be using SQL login rather than Windows login. When using SQL Server Authentication rather than Windows Authentication, within the report, the dynamic parameter works fine when published to Crystal Server.

Share
10 |10000 characters needed characters left characters exceeded
Scott Shelton Apr 11 at 06:57 PM
0

I have isolated this to reports that are pulling for SQL, as similar report pulling from Oracle are working with dynamic parameters. Still not sure why this is happening, though?

Additionally, the dynamic parameters are working when being previewed in Crystal Reports 2016, but not working when being viewed in Crystal Server 2016.

Share
10 |10000 characters needed characters left characters exceeded