Skip to Content
avatar image
Former Member

Using an uwl iviewlauncher in a Federated portal network

Hi

We have a problem when we are using an iviewlauncher (uwl iview) in the consumer portal to launch a portal page/webdynpro iview. The problem is that the webdynpro application does not get the url dynamic parameter info that we are submitting. It works perfectly when we are navigating directly to the producer portal but not when we have a remote role assignment in the consumer portal. The difference in urls , directly navigating to the producer portal and when navigating to the consumer, is the following:

Directly to the producer:

/prteventname/Navigate/prtroot/pcd!3aportal_content!2fevery_user!2fgeneral!2fdefaultDesktop!2fframeworkPages!2fframeworkpage!2fcom.sap.portal.innerpage!2fcom.sap.portal.contentarea

?NavigationTarget=ROLES%3A%2F%2Fportal_content%2FXXX%2Fcrm%2Fforsaljning%2Froller%2Fteamassistent%2Fforsaljning%2Fsaljfloden%2Fsaljflode%2Faffarstips&workitemId=000017690258&wi_id=000017690258&destination=SAP_CRM&item_id=1440&task=TS90100219&logsys=TS90100219&uname=XXX&langu=SV&CurrentWindowId=WID1221911615325&NavMode=1

Via the consumer portal:

/prteventname/Navigate/prteventdata/

NavigationTarget!3dROLES!253a!252f!252fportal_content!252fse.posten.pct!252fcrm!252fforsaljning!252froller!252fteamassistent!252fforsaljning!252fsaljfloden!252fsaljflode!252faffarstips!26wi_id!3d000017690258!26workitemId!3d000017690258!26task!3dTS90100219!26CurrentWindowId!3dWID1221910314991!26langu!3dSV!26logsys!3dTS90100219!26NavMode!3d1!26destination!3dSAP_CRM!26RelativeNavBase!3d!26uname!3dGOWE703!26item_id!3d1440/prtroot/pcd!3aportal_content!2fse.xxxx.pct!2fcrm!2fforsaljning!2froller!2fteamassistent!2fforsaljning!2fsaljfloden!2fsaljflode!2faffarstips

The one difference that I can see directly is that when navigating via the consumer there are no url parameters in the request since the url parameter always starts with a question mark (hex: 3F). Is it a bug or do I need to read the parameter values from an event instead when navigating via the consumer portal?

br

Göran

Edited by: Göran Westin on Sep 23, 2008 1:54 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Mar 23, 2009 at 08:53 AM

    After getting a hotfix from SAP the problem was solved. Accordingly to the SAP contact person the fix will be part of support package 19 for NW 7.0.

    Add comment
    10|10000 characters needed characters exceeded