Skip to Content
author's profile photo Former Member
Former Member

Flat File DataSource doesn't load properly.

Hi all,

we have a data file, which is tab delimited, saved as CSV and text versions. i have created a flat file datasource, mapped all fields.

I can load CSV version fine, but when use it on text version, it doesn't like it and can only return column one with the rest of the column blanked in the preview tab.

Setting:

In the "General" tab, everything is unchecked.

In Extraction tab, Adapter - "Load Text-Type File from Local Workstation"

Character settings - "Default setting"

Data format - "Separated with Separator"

Data separator - tab (00BB Hex)

Escape Sign - CR (00B6 Hex)

Number format - Direct entry

Thousand Separator - ","

Decimal point - "."

i have tried different setting, change number format to "User Master Records".

With the text version, the result in Preview can only display first column and Proposal preview can only shows one column. There is no error returned from the text version.

The CSV version can display all data and they are aligned as well.

what do i miss? is the text file not saved correctly? i can see all tabs and CR in the text version. it seems to be the tab is not detected properly or something.

Regards

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 23, 2008 at 06:18 AM

    Hi,

    Have a look at the below link:

    Loading Text Files(.TXT) into BW with HEX option

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 23, 2008 at 06:31 AM

    Hi,

    Data separator should be "," and not tab in case of comma separated values "CSV" files. Change this setting and it should work then.

    Hope that helps.

    Regards

    Mr Kapadia

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.