Skip to Content
Former Member
Sep 22, 2008 at 03:42 PM

Remaining text error when changing the database in use



This is my first post on this forum. I tried searching for this problem but could not find anything.

I have a VS2005 Winforms application using a number of reports. The approach that I have taken is:

report = new ReportDocument();

this.crystalViewer.ReportSource = report;


where the datatable is populated with the results of a stored proc execution on SQL Server, and the last line is a virtual function that populates any parameters required by the report. The reports were originally created by referencing the stored proc on a test database, and everything worked great. The reports ran correctly in the design environment and in the application.

Then I moved the application to a production database on the same server. This was done by changing a connection string parameter used by the sproc that populates the dataset. Now all the reports, including several that take no parameters, fail with the error message:

The remaining text does not appear to be part of the formula


Error in formula <Record_Selection>


The remaining text does not appear to be part of the formula

None of the reports have a formula called <Record_Selection>, so I am assuming that this is an internal function of some sort.

The databases are essentially identical and I have tested the sprocs in the new database. I have also confirmed that the data table is correctly populated before the above code is executed.

Any ideas why this is happening and what I can do to stop this error?

Many thanks


Edited by: Jonathan Dienst on Sep 22, 2008 5:47 PM