Skip to Content

C4C to PI communication error

Dear all,

we implemented a C4C to SAP integration using SAP PO.

Everything worked fine until 2 weeks ago, but now sometimes we have this error:

"SRT: Processing error in Internet Communication Framework: ("ICF Error when receiving the response: ICM_HTTP_SSL_ERROR")"

This is random situation, so every 20 or 100 messages we have one in error:

If we try to re-process this message then it is delivered without problem.

How is possible? where we can check this issue? it's a networking problem?

Best regards

Alessandro




Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Apr 12 at 02:50 PM

    Dear Alessandro,

    This is very strange that you get SSL error, and reprocessing the messages it works fine. Ideally SSL error comes up when there are missing or incorrect server certificates uploaded in C4C trust list.

    First thing which you can check from your end is, trace logs from your system. I would assume that you have some sort of interim system between C4C and PO, like Web-Dispatcher, Firewall or Proxy.

    Try to get logs from this system, also check where exactly the SSL termination happening, your Basis or Network team can help here.

    Get the updated certificates from your Basis teams, and re-upload them in C4C again, delete the existing ones.

    If the issue still persists, then kindly report an incident to SAP.

    Hope this gives you some pointers.

    Regards,

    Shivanand B H

    Add comment
    10|10000 characters needed characters exceeded