Skip to Content
0

AWS CAL Hana Express 2.0: No webide accessible

Apr 10 at 12:20 PM

36

avatar image

I have deployed Hana Express 2.0 on AWS today, all worked well.

When I try to open webide it says "this site can't be reached".

http://ec2-xxxx.eu-central-1.compute.amazonaws.com:53075/

This is quite understandable.
http://ec2-xxxx.eu-central-1.compute.amazonaws.com:8090/ shows the static web page that XSC is up.

When I run the commands

  • xs api https://vhcalhxedb:39030 --cacert /hana/shared/HXE/xs/controller_data/controller/ssl-pub/router/default.root.crt.pem
  • xs l (with https://vhcalhxedb:39030; XSA_ADMIN; SAP)
  • xs apps

It lists all elements including webide. Not started initially but after a while it says 1 of 1 instances started.

Now I open

https://ec2-xxxx.eu-central-1.compute.amazonaws.com:53075

and it redirects to

https://vhcalhxedb:39032/uaa-security/oauth/authorize....

Of course the hostname vhcalhxedb cannot be found. And why it redirects to this hostname is clear as well - why it does change the hostname is not, but that's another story - it is the URL of the xs apps.

I have tried multiple methods to modify the xsa apps default domain but they all fail one place or the other.

Would be good to add that to the Getting Started document and frankly I don't know a good solution to solve that problem still.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Lucia Subatin
Apr 10 at 02:12 PM
0

Hi, Werner,

Is it fair to say that your question is how to rename the default domain?

Share
10 |10000 characters needed characters left characters exceeded