Skip to Content
0

BI Support Tool : Connection to the request port failed

Apr 10 at 11:32 AM

50

avatar image

Hi Everyone,

I just installed BI Platform Support tool for BI 4.1 version on a server. Successfully installed and configured JMX to resolve tomcat issues.

But now, while configuring landscapes (tried executing it via Landscapes Configuration / Landscape tools --> Communication analyzer), am getting the following Login error:

The connection to the name server port 6400 was successful but the connection to the request port failed. Ensure the server is reachable by hostname and the request port is open. For more information, refer to the following comment SAP KBA 2151044

Host file has been updated with server and ip address details. I have tried giving hostname, hostname with fqdn, ip address in CMS field.

When I perform communication test, get the following message:

A successful TCP connection was made to xxxxx:6400

As per the guide, server.xml is updated with tomcat remote JMX listener -10001 and 10002. But when I run netstat command for 100001 and 10002 (netstat -noa | findstr 10001 and netstat -noa | findstr 10001) in command prompts, nothing happens and I get blank result.

Please let me know if I am missing something here.

Thanks in advance,

bipts-error.pngJaya

bipts-error.png (23.7 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Toby Johnston
Apr 10 at 12:48 PM
0

Hi Jaya,

I have a few questions to help us narrow down the problem:

  1. What happens if you perform a communication analyzer test to the CMS hostname and request port? Is this working?
  2. Go to the BI 4.1 server and open a command prompt and run ipconfig -a, and then run hostname. Record the results for these two commands.

    Next, go to the client computer where you are running the BIPST 2.1. Open a command prompt and run the command ping cmshostname (where cmshostname is your cms host).

    Is the IP Address you got using ipconfig -a on the server match the IP Address that was returned when you ran ping command on the client?

    Is the host name you got from the hostname command on the server the same as the hostname you added to the /etc/hosts file on the client?
  3. On your BIPST client, are you able to connect to the CMS using other BI tools such as Information Design Tool or Webi Rich Client?

Let me know what you discover.

Regards
Toby

Show 8 Share
10 |10000 characters needed characters left characters exceeded

Hi Toby,

Thanks for your suggestions!
Here are the answers in line.

1. As mentioned in my post and attachment, test throws successful message "A successful TCP connection was made to xxxxx:6400". And when I execute it, I get the following error message:

The connection to the name server port 6400 was successful but the connection to the request port failed. Ensure the server is reachable by hostname and the request port is open. For more information, refer to the following comment SAP KBA 2151044

2. ipconfig -a command throws error message "unrecognized and incomplete command line". But I tried with ipconfig and ip address from BO server matches with the one received from BIPST client server.

3. This was interesting, could not connect to the CMS in webi rich client. It threw an error message "Server XXXX not found or may be down". However, I could connect to the same CMS on BO server.

Thanks,

Jaya

0

Hi Jaya,

The CMS requires two communication ports. 6400 is the nameserver port and there should also be a request port. Go to the CMC-->Servers and look at the properties of your Central Management Server. Here you can find the request port for the CMS. Try setting this to a static port number (disable auto assign) and restart the CMS.

Then, test communication for this port between your client and the BI server (in the above example, port 8400)

Regards
Toby

rp.png (32.6 kB)
0

Hi Toby,

How do we decide on this static port number? Should it be in reference to something at the server level?

Thanks for your help!
Jaya

0

Hi Jaya,

It can be any number (within the valid TCP port range) and the port should be free on the server (no other process is configured to use this port).

You can check this via command prompt using netstat. For example:

netstat -noa | findstr 8400

If nothing comes up as a result then port 8400 is free to use.

Regards
Toby

0

Hi Toby,

I checked for netstat and got blank for 8400. So, updated 8400 for request port number and restarted CMS service and SIA as well. But still, the same issue :(

Please note netstat command returns TCP related results.

Not sure, where else I need to make changes :(

Thanks

Jaya

0

Also, please note that SIA has some cluster related issues on BIPS client server. Hope that shouldnt be a problem to connect to a different BO server.

0

Hi Jaya,

Once you have setup CMS request port to 8400 then you should test the communication between BIPST client and the server on port 8400. If this test fails, then you have a firewall blocking this port between client and server. If this is the case, you would need to ask your network admin to allow communication on both 6400 and 8400 tcp ports.

Let me know what you find out.

Thanks
Toby

0

Hi Toby,

I have requested network team to open communication on both 6400 and 8400 tcp ports. Will check once they open it and provide an update.

Thanks for your help!
Jaya

0
Toby Johnston
Apr 10 at 03:49 PM
0

Hi Jaya,

Once you have setup CMS request port to 8400 then you should test the communication between BIPST client and the server on port 8400. If this test fails, then you have a firewall blocking this port between client and server.

Let me know what you find out.

Thanks
Toby

Share
10 |10000 characters needed characters left characters exceeded
Jayalakshmi S 2 days ago
0

Hi Toby,

My network team confirmed that they are not behind any firewall managed by Perimeter protection group therefore the blocking should be at server or service level.

Thanks,

Jaya

Share
10 |10000 characters needed characters left characters exceeded