Skip to Content
avatar image
Former Member

Publish Service from ABAP to Service registry

Hello,

We have recently upgraded XI to PI 7.1.

Our backend Business system is still on NW 6.4.

We have web services that are implemented on the backend 6.40 that we are trying to publish to PI 7.1 service registry.

I have setup RFC destination on the ABAP as follows

Connectioon Type - G (HTTP connection to Ext Server)

Target Host - xyz (PI 7.1 host) Service No. - 50000

Path Prefix - /uddi/api/inquiry/

When I test the connection, I get 404 Not Found error.

Whats wrong with my setup? Am I missing something here?

Regards

Haseeb

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Sep 22, 2008 at 02:42 PM

    Any ideas?

    Regards

    Haseeb

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Rathish,

      Thanks for your detailed response.

      Yes we have UDDI server working fine on PI 7.1. I am able to publish WSDL directly from service repository to service registry.

      The problem is publishing the web service I implemented in our ABAP backend system (ECC 5.0 on 6.40).

      I had created service registry entry in SUDDIREG.

      I have also created two HTTP destination for inquiry and publish.

      Target Host - PI 7.1 host

      Path Prefix for Inquiry destination - /uddi/api/inquiry/

      Path Prefix for Publish destination - /uddi/api/publish/

      In SE80, when I doubleclick the web service, I see UDDI tab and a publish button in there. When I click the Publish button, I can select the registry I defined in SUDDIREG and then it prompts for userid and password. I do not get any error then and I see an entry of the registry under UDDI tab for the web service in SE80.

      However, when I logged into service registry , I dont see the web service published in there. Based on furhter investigation, I found a program "UDDICL_CHECK" and when I execute, I see an entry for the web service I published with error message "Entry Inconsistent".

      I really appreciate your help and hopefully we can resolve this problem.

      Regards

      Haseeb