Skip to Content
Former Member
Sep 19, 2008 at 02:11 PM

UI Config Tool: Not able to retain a modification for custom configuration



I am trying to add a field from "Available" to "Displayed" in the component BT127I_ACTI, view ActIEFJournal. I copied the default configuration into a custom one with my Role Config Key. Now, I'm trying to modify the view by moving one field out of the displayed and adding another to displayed. In the UI Config tool everything works just fine. I am able to save a modified configuration and attach it to a transport (I checked the transport - it contains the correct entries.) At this moment, everything is as expected.

However, when I run my UI, and call the view in the browser, my modifications aren't seen as if they never got carried out: everything resets to the prior state of the view (of course, I checked F2, and it showed me the correct Config Key, so it's not a reason.) Moreover, when I'm opening the UI Config tool again, all the changes that I have just made are gone!!!!! What's going on? It didn't happen with other components/views.

FYI, the view doesn't have an iterator as in IS-U components; hence, it's not the iterator that overwrites the UI config changes.

Has anyone seen anything like it before. If so, could you please, share your experience, especially if you had solved the problem

Thank you