Skip to Content
0

Weird report fields ONLY when printing in .NET winforms application

Apr 11 at 07:25 AM

51

avatar image

I have a strange behavior since three months till today that has been get worse in last week. The application prints reports well and all is going perfectly since with no special reason it starts to printing in a weird format, some fields dissapears and other as misplaced.

If we export to pdf all is in its place but when print to printer all goes crazy.

As I told, the problem ONLY occurs when printing and it appears randomly after some printings so it's very hard to debug for us and

some costumers prints about 1000 sheets every day... so we have a big problem right now.

This is a capture of the problem:

And this is how it shoud look:

Our configuration:

  1. In Visual Studio 2017 we have references for CrystalDecisions.CrystalReports.Engine 13.0.3500.0 file version 13.0.21.2533 (all the references in project about CrystalReprots have the same version)
  2. All the deployment machines have installed SAP Crystal Reportrs runtime engine for .NET framework 13.0.21.2533
  3. The reports have "No printer (optimize for screen display)" flag checked. Also we've tried with the deployment printer with no luck.
  4. All reports are made with Crystal Reports 2016 with Support Pack 5 (14.2.5.2618)

We made a lot of testings but have no luck solving this.

Could you help us?

captura-ok.jpg (160.7 kB)
captura-fin.jpg (230.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Franc Muñoz 5 days ago
0

Finally I found the cause of our issue

We have a control that have a custom message processing using Graphics on a wndproc overrides. When this control receives the wndproc message and draws something... crystal reports fails.

I don't know the reason just used other approach to do custom drawings and all is working fine.

Based on all the information collected I guess this is a windows 10 issue, because it appeared after SP22 and it was suddenly, apparently after a windows update... so I guess we found a poltergeist case... Surely somebody can explain why, I don't have enough energy right now to wonder th reason.

Thank you Don for your suport, we aprreciate your effort.

Share
10 |10000 characters needed characters left characters exceeded
Don Williams
Apr 12 at 03:45 PM
0

Hi Franc,

I believe that is a known issue. I reported something similar to R&D and just before SP 22 was released, We both confirmed it was fixed in SP 22.

See if that resolves the issue?

https://wiki.scn.sap.com/wiki/display/BOBJ/Crystal+Reports%2C+Developer+for+Visual+Studio+Downloads

Thanks

Don

Share
10 |10000 characters needed characters left characters exceeded
Franc Muñoz 6 days ago
0

Hi Don!

Thank you for your reply. Unfortunately it didn't worked. We've updated to SP 22 (13.0.22.2668 files have date Jan-9-2018) both VS and Redist on some machines to test. All of them still having the same issue.

We've noticed if we put misplaced or lost field into a textfield it works We could change all of our reports since it works, but I think it's an odd solution (a lot of work making a nonsense operation). But I think It would help to determine the cause of the bug.

The systems have different printers and drivers (HP, Canon, Samsung, Brother) and we tested with different drivers so printer drivers aren't the cause.

Do you have any idea? We're having very problems since our clients are getting tired of this. Could you please tell me how can notify or open a bug. It's important for us to solve this problem as soon as possible.

Could you tell me where are the reported issues similar to mine? We're working all the day on in and all information i can get will be welcome.

Could you help us please?

Share
10 |10000 characters needed characters left characters exceeded